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What’s New

Overview

The SAS Intelligence Platform: Desktop Application Administration Guide contains
new and updated administrative tasks that are associated with seven client
applications.

Documentation Enhancements

For SAS 9.2, the SAS Intelligence Platform: Desktop Application Administration
Guide contains the following enhancements:

0 A new Common Elements chapter addresses administrative tasks that are
common to all or most of the desktop applications.

0 The SAS Data Integration Studio chapter contains new material that addresses
data server connections, message queue administration, Web service support, bulk
loading of data, and external file wizard configuration.

0 The SAS Enterprise Miner chapter contains revised information for the model
viewer, the Analytics Platform, and the Tomcat WebDAV server.

0 The SAS Management Console chapter introduces new administrative capabilities
and describes how to start the client using a symbolic link.

0 In the second maintenance release for SAS 9.2, the SAS Enterprise Guide chapter
has been updated to document the registration of custom tasks as capabilities.

0 In the second maintenance release for SAS 9.2, the chapters for SAS Management
Console, SAS Add-In for Microsoft Office, and SAS Enterprise Guide have been
updated to document default roles and capabilities.

0 In the third maintenance release for SAS 9.2, the following chapters have been
updated:

0 the SAS Enterprise Miner chapter, to include SAS Enterprise Miner 6.2
0 the SAS Data Integration Studio chapter, to include SAS Data Integration
Studio 4.2

Other chapters received minor updates, corrections, and additions.
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About the Desktop Applications

The SAS Intelligence Platform includes the following desktop applications:

SAS Add-In for Microsoft Office
brings the power of SAS to Microsoft Excel, Word, and PowerPoint.

SAS Data Integration Studio
enables enterprise data collection, analysis, reporting, and publishing using a
graphical process designer and numerous data transformation templates.

SAS Enterprise Guide
provides a point-and-click interface for data querying, reporting, analysis, and SAS
programming.

SAS Enterprise Miner
provides a point-and-click interface for creating predictive models that identify
trends, opportunities, and threats based on the analysis of data from across your
enterprise.

SAS Information Map Studio
provides a point-and-click interface for the creation and maintenance of
information maps. Information maps are metadata definitions of enterprise data
that provide a basis for querying and reporting.

SAS Management Console
provides the primary administrative interface for the SAS Intelligence Platform.

SAS OLAP Cube Studio
provides a straightforward wizard interface for building, updating, and tuning
SAS OLAP cubes.

Administrative information for client applications that run in a Web browser is
provided in the SAS Intelligence Platform: Web Application Administration Guide, at
http://support.sas.com/documentation/onlinedoc/sas9doc.html. The Web
applications include SAS Web Report Studio, SAS Web OLAP Viewer, and the SAS
Information Delivery Portal.
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Installation Notes for Desktop Applications

You initially install desktop applications as part of your overall deployment plan, as
described in the SAS Intelligence Platform: Installation and Configuration Guide.

After you install a desktop application, it is important for you to know that the
configuration process might not end at that point. Check the chapter in this document
for each desktop application to ensure that you complete the configuration process. You
might need to configure libraries, update user permissions, or change memory
allocations.

Accessibility Features in the SAS Desktop Clients

For information about accessibility for any of the products mentioned in this book,
see the documentation for that product.

For assistive technologies based on Windows, you need to download the Java Access
Bridge (JAB) from Sun Microsystems at this URL: http://www.java.sun.com/
products/accessbridge/. The SAS Java applications that run on Windows are listed
under “Clients” in the “Architecture of the SAS Intelligence Platform” chapter of the
SAS Intelligence Platform: Ouverview.

After downloading the JAB, you need to customize the standard installation
procedure to facilitate access to it. This setup assumes that Java is already installed on
the machine. A known risk is that SAS applications can be corrupted by JAR files that
might be installed in the jre/lib/ext directory. To solve this problem, SAS has
implemented a custom class loader to replace the system class loader. The custom class
loader loads only approved extensions that SAS configures based on the JRE the vendor
provides. A consequence of hiding the existing directory is that it disables installed
accessibility-related applications. To configure SAS Java applications to permit access
to the Java Access Bridge:

1 On the client machine, locate all copies of the file sas.java.ext.config.

2 In each instance of the file, edit the file in a plain text editor, such as Microsoft
Notepad.

3 Add the following two lines to the bottom of the file:

access-bridge. jar
jaccess-1_4.jar

Note: The filename of the jaccess*.jar file depends on the version of the JRE.
Listed here is the filename for Version 1.4. If you are using a different version,
your filename varies.

4 Save the changes and close the file.

Note: If your site runs desktop applications on remote hosts, assistive technologies,
such as JAWS screen reader, might require additional licensing and configuration to be
fully functional. This situation has been observed when applications are executed with
Citrix software. A

If you have questions or concerns about the accessibility of SAS products, send e-mail
to accessibility@sas.com.


http://www.java.sun.com/products/accessbridge/
http://www.java.sun.com/products/accessbridge/

CHAPTER

Common Elements

Overview 3
Migrating Desktop Applications 3
Administering Connection Profiles for Desktop Applications 4
Overview of Connection Profiles 4
About Integrated Windows Authentication 4
About Default Connection Profiles 4
Disable the Option to Store Credentials in Profiles 5
Change, Create, Delete, or Edit a Connection Profile 5
Administering Roles and Capabilities 6
Administering Logs and Other Local Files 6
About the Desktop Application Log Files 6
Managing the Java Heap Used By Desktop Applications 1

Overview

The common elements in the administration of desktop applications include logging
and local files, heap (memory) management, connection profiles, and roles and
capabilities. The common elements apply to the group of desktop applications that are
unique to the SAS Intelligence Platform: SAS Management Console, SAS Data
Integration Studio, SAS OLAP Cube Studio, and SAS Information Map Studio.

Migrating Desktop Applications

The desktop applications do not have an explicit migration path. You simply remove
the previous version and install the new version in its place. When you start the desktop
applications for the first time, the application makes whatever migrations are necessary.

CAUTION:
Do not run the SAS Migration Utility on hosts that run desktop applications. »

For a description of application changes, refer to the What’s New and Special
Considerations documents.
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Administering Connection Profiles for Desktop Applications

Overview of Connection Profiles

During initialization, SAS desktop applications use a connection profile to connect to
a SAS Metadata Server. A successful connection enables secure access to the enterprise
resources that are defined in metadata.

Connection profiles are stored on the hosts of the desktop applications at
C:\Documents and Settings\user name\Application
Data\SAS\MetadataServerProfiles. In the Windows Vista operating environment,
the path is c:\Users\user-name\AppData\Roaming\SAS\MetadataServerProfiles.
The names of the profiles use the file extension .swa.

Selecting a different profile closes all server connections and terminates any active
jobs.

Connections depend on the version of the SAS Metadata Server. Older desktop
applications that were delivered with the SAS 9.1.3 connect only to the SAS 9.1.3
Metadata Server. Newer applications that were delivered with SAS 9.2 connect only to
the SAS 9.2 Metadata Server.

Users can change, edit, or delete connection profiles at any time.

A successful connection to a metadata server is required to fully initialize the
following desktop applications:

0 SAS Data Integration Studio

0 SAS Information Map Studio
0 SAS Management Console
i

SAS OLAP Cube Studio
The preceding applications use a common interface for connection profiles, as described

in this section.
The following desktop applications use a different interface for connection profiles:

0 SAS Enterprise Guide
o SAS Add-In for Microsoft Office
o SAS Enterprise Miner

Connection profile information for the preceding applications is provided in the chapters
of this book that are dedicated to those applications.

About Integrated Windows Authentication

Connection profiles enable users to specify that authentication be performed using
Integrated Windows authentication. This type of authentication enables users to
connect to SAS Metadata Servers and SAS Workspace Servers without transmitting a
name and password over the network. The client and server transmit authentication
tokens to a host, and that host confirms or denies the authentication.

Integrated Windows authentication applies only to servers that are installed on a
Windows host. For more information about Integrated Windows authentication, see the
SAS Intelligence Platform: Security Administration Guide.

Ahout Default Connection Profiles

At installation time, most of the desktop applications create a default connection
profile. For all of these applications other than SAS Management Console, the default
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connection profile prompts users to authenticate using credentials from the operating
environment. The resulting connection provides information that enables the
assignment of permissions.

After you install a desktop application, users should be directed to create new
connection profiles. The new profile implements the users, groups, and roles that are
defined at your site.

Disable the Option to Store Credentials in Profiles

When you create a connection profile, the Connection Profile Wizard provides, by
default, a check box named Save user ID and password in this profile. If a user
selects this check box, then the user’s ID and password are stored in the user’s
connection profile on the local file system. Saving the ID and password in the profile
allows users to reconnect in the future without entering these values again.

Follow these steps to remove the Save user ID and password in this profile
check box from the Connection Profile Wizard and require the manual entry of
credentials:

1 On the host of the SAS Metadata Server, open in a text editor the file
omaconfig.xml.

2 Change the value of the option SASSEC_LOCAL_PW_SAVE from 1 (or ¥ or T) to 0
(or N or F).

3 Save and close the file.

4 Restart the SAS Metadata Server as directed in the SAS Intelligence Platform:
System Administration Guide.

After you change the setting for this option and restart the metadata server, each
client uses the previous setting for its first connection. The client then discovers the
revised setting and conforms to that revised setting for subsequent connections.

If you change the setting to disallow saved credentials, and credentials are already
present in a user’s connection profile, those credentials must be manually removed.

Change, Create, Delete, or Edit a Connection Profile

To create, change, delete, or edit a connection profile, follow these steps:

1 Open the desktop application. If you specified a connection profile previously, then
the application uses that profile.

2 If directed to do so, enter your user ID and password.

3 Select File » Connection Profile and click Yes to display the Connection Profile
window.

4 To change from the current profile to another profile, click the down arrow, select
the other profile, and click OK.

5 To delete an existing profile, click Delete and Yes. Deletion removes all of the
connection information in that profile. Select another profile to continue using the
application.

6 To edit an existing connection profile, click the down arrow to select the profile,
and then click Edit to open the Edit Connection Profile wizard. Add profile
information as directed by the wizard, and then click Finish. In the Connection
Profile window, click OK to connect to the specified SAS Metadata Server using the
edited profile.
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7 To create a new connection profile, click Create a New Connection Profile and
click ok to display the Connection Profile Wizard. Add profile information as
directed by the wizard, and then click Finish. In the Connection Profile window,
click oK to connect to the specified SAS Metadata Server using the new profile.

Administering Roles and Capabilities

When users are assigned to roles, they gain access to certain capabilities in certain
applications. Roles are implemented in the following desktop applications:

SAS Management Console
See “Administering Roles” on page 69.

SAS Enterprise Guide
See “Default Roles and Capabilities for SAS Enterprise Guide” on page 47 and
“Registering Custom Tasks as Capabilities in SAS Enterprise Guide” on page 54.

SAS Add-In for Microsoft Office
See “Default Roles and Capabilities for the SAS Add-In for Microsoft Office” on
page 11 and “Registering Custom Tasks as Capabilities in the SAS Add-In for
Microsoft Office” on page 19.

Roles and capabilities are also implemented in SAS Web Report Studio, as described in
the SAS Intelligence Platform: Web Application Administration Guide.

Roles are added, deleted, and changed in the User Manager in SAS Management
Console.

For more information about roles and capabilities, see the SAS Intelligence Platform:
Security Administration Guide.

Administering Logs and Other Local Files

The desktop applications maintain local files on the C: drives of their respective
hosts. Local files contain information that is specific to users.

By default, in the Windows operating environment, local files are stored in the
Documents and Settings directory.

Windows path to local files:
C:\Documents and Settings\user-name\Application Data\SAS\applicationName

Connection profiles:
C:\Documents and Settings\user-name\Application
Data\SAS\MetadataServerProfiles

Log files:
C:\Documents and Settings\user-name\Application Data\SAS\Logs

The Windows Vista operating environment uses the following path:
C:\Users\user-name\AppData\Roaming\SAS\

About the Desktop Application Log Files

The Logs directory contains the following log files for the following desktop
applications: SAS Management Console, SAS Data Integration Studio, SAS OLAP Cube
Studio, and SAS Information Map Studio.
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Table 2.1 Log Files Created by Desktop Applications

Action Source Filename

Import package SAS Import Package Wizard Import_yyMMddHHmmss.log
Export package SAS Export Package Wizard Export_yyMMddHHmmss.log
Batch import Import Package Tool Import_yyMMddHHmmss.log
Batch export Export Package Tool Export_yyMMddHHmmss.log
Copy, paste, and paste Edit menu CopyPaste.log

special

For information about importing and exporting, see the chapter “Creating,
Registering, Moving, Copying, Renaming, and Deleting SAS Metadata Repositories” in
the SAS Intelligence Platform: System Administration Guide. For information about
logging, see the chapter “System Monitoring and Logging” in the SAS Intelligence
Platform: System Administration Guide.

Managing the Java Heap Used By Desktop Applications

The Java heap is a segment of host memory that certain desktop applications use to
manage their graphical user interface. The size of the Java heap is 512 megabytes for
SAS Management Console, SAS Data Integration Studio, and SAS OLAP Cube Studio.
SAS Information Map Studio dynamically allocates heap memory, using a minimum of
500 megabytes and a maximum of 1024 megabytes.

Follow these steps if you need to increase the size of the Java heap for one of the
preceding desktop applications:

1 Open the application’s INI file using the path
SAS-installation-directory\SAS\application-name\release-number. Note
that your site might use a different installation directory for SAS.

2 Increase the default value Xmx512m to something higher, such as Xmx1024m.

3 Save and close the INI file.

4 Restart the desktop application.

If your desktop applications run in the Citrix application delivery environment, then
you can increase the size of your Java heap to the Citrix limit. Although some versions
of Citrix support higher limits, all versions support a maximum Java heap size of 512
megabytes.
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SAS Add-In for Microsoft Office Overview

The SAS Add-In for Microsoft Office is a Component Object Model (COM) add-in. It
extends Microsoft Office to use the power of SAS data access, analysis, and reporting
directly from Microsoft Excel, Microsoft Word, and Microsoft PowerPoint. To see the
power of SAS in Excel, Word, or PowerPoint:

0 In Microsoft Office 2000-2003, open the SAS menu.

0 In Microsoft Office 2007, click the sAs tab in the Ribbon. Several groups with
related SAS tasks are displayed.

After you install the SAS Add-In for Microsoft Office, certain administrative tasks
need to be completed.
The administrative tasks are summarized in the following table.

Table 3.1 Administrative Tasks for SAS Add-In for Microsoft Office

Administrative Task Purpose of Task

Administer a connection profile Add, modify, or delete a profile. Set the active
profile.

Select a default server Specify which server you want to access by

default.
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Administrative Task

Purpose of Task

Administer profile configuration updates

Administer files

Administer roles

Grant library access

Create a configuration update file that can be
modified and used each time the Microsoft
applications are initialized.

Specify the location of the add-in administration
files.

Limit access to certain features for certain users.

Administer access to registered libraries.

For additional information about using the SAS Add-In for Microsoft Office, see the
following:

o In Microsoft Office 2000-2003, click SAS » Help » SAS Add-In for Microsoft
Office Help.

o In Microsoft Office 2007, click SAS » Help » SAS Add-In for Microsoft Office
Help.

0 The product web page: http://support.sas.com/documentation/onlinedoc/
addin/index.html.

Administer a Connection Profile for the SAS Add-In for Microsoft Office

A connection profile defines the connection between the SAS Add-In for Microsoft
Office and a SAS Metadata Server. The SAS Metadata Server contains metadata
definitions for objects such as workspace servers, libraries, and users. These definitions
are used by the add-in and other SAS applications. The SAS Metadata Server
connection provides secure access to enterprise servers and data sources.

The Connections window provides the interface to Profiles, Servers, and Updates.
Any changes made to the connections are applied to SAS Enterprise Guide and to all
Microsoft applications that use the add-in. To access the Connections window, follow
these steps:

O In Microsoft Office 2000-2003, select SAS » Tools » Connections

o In Microsoft Office 2007, select the saAs tab in the Ribbon, and select Tools »
Connections. The Connections appears.

To configure the Profiles, Servers and Updates, refer to the online Help.

o In Microsoft Office 2000-2003, click SAS » Help » SAS Add-In for Microsoft
Office Help.

o In Microsoft Office 2007, click SAS » Help » SAS Add-In for Microsoft Office
Help.

Select No-Profile Mode

You can create a second profile that connects you to the metadata repository that is
installed on the local host. This type of profile supports single-machine configurations.
You can also use the add-in without a profile, although you can access only a SAS
server installed on your local machine.

To invoke no-profile mode, open the Connections window by selecting SAS » Tools »
Connections. The Connections window is displayed. Select Profiles from the list of
available profile-related actions. Then select <do not use profile> from the list of
profiles that have been defined. An icon identifies the active profile.
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Select a Default Server for the SAS Add-In for Microsoft Office

Using the Connections window, you can specify which server you want to access. You
connect to a server to access data sources and to run SAS tasks. To select a server for
the active profile, follow these steps:

1 On the client machine, open a Microsoft Office application and click the sas tab.

2 Click Tools » Connections.

3 Click servers, click the down arrow, and select a default SAS server.

4 (Optional) Click the check box Automatically add local SAS server (if
installed) to the list.

For additional information, see “Select a Default SAS Workspace Server in SAS
Enterprise Guide” on page 45.

Note: Performance improvements can be achieved when groups of users select a
load-balancing cluster of SAS Workspace Servers. For information about load-balancing,
see the SAS Intelligence Platform: Application Server Administration Guide. 1

Administer Profile Configuration Updates for the SAS Add-In for
Microsoft Office

You can create an update configuration file. When used, the connection profiles of
specified users are automatically updated according to the contents of the update
configuration file. The profiles are updated before the users invoke the profile, during
the initialization of a Microsoft Office application.

For more information about update configuration files, see “Administer Connection
Profiles in SAS Enterprise Guide” on page 44. See the SAS Add-In for Microsoft Office
Help for detailed information about how to automatically update the configuration for
your connection.

Files Created by the SAS Add-In for Microsoft Office

By default, the SAS Add-In for Microsoft Office generates various files, including
configuration files and log files. These files are located, by default, in C:\Documents
and Settings\user ID\Application
Data\SAS\Add-InForMicrosoftOffice\release-number.

Default Roles and Capabilities for the SAS Add-In for Microsoft Office

As described in the SAS Intelligence Platform: Security Administration Guide, you
can assign users to roles to provide access to selected capabilities in the SAS Add-In for
Microsoft Office.

Using SAS Management Console, as described in “Administering Roles and
Capabilities” on page 6, you can assign users to roles, change the capabilities that are
enabled by each role, and create new roles with unique sets of capabilities.

The User Manager in SAS Management Console provides three default roles for the
SAS Add-In for Microsoft Office: Advanced, OLAP, and Analysis. The following table
describes the capabilities that are assigned by default to these roles.
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Table 3.2 Default Capabilities Assigned to Roles for the SAS Add-In for Microsoft Office

Role

Capability Description Advanced OLAP Analysis
Open or Import
Category
Open Files from Open files from the local file system. X X X
Local Computer Not a substitute for system security.
Open Cube from Open cube source data into a X X
OLAP Servers document.
Save or Distribute
Category
Modify Output Data  Change the output location in tasks X X
Location in SAS that have an output location.
Tasks
Copy and Paste SAS  Copy or paste from a server or library. X X
Server Content Not a substitute for system security.
Publish To Send content to a channel such as X
Distribution e-mail or Web, modify channel
Channels properties.
Content Category
Add or Modify Edit custom code runs before or after X
Custom Code to SAS  SAS tasks.
Tasks
Options Category
Modify SAS Server Enable server reassignment in SAS X X
Reference in Project content.
or Document
Modify Security Change security options for documents. X
Options
Modify E-mail Change e-mail options for documents. X
Options
Modify All Options Change all options in the SAS Add-In X

Options window.
Tools and Help
Category
Access Unregistered  Edit or run unregistered tasks if X
Custom Tasks security enables access.
Modify Styles Change ODS output styles. X
Create or Modify Change document refresh schedules or X X
Schedules scheduling options.
Access SAS Use the Help menu to navigate to SAS X

Technical Support

technical support.
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Role
Capability Description Advanced OLAP Analysis
Data Category
Copy to SAS Server Copy active data to a SAS server. X X X
Compare Data Create a report that compares two X X X
data sets or two variables across
multiple data sets.
Data Set Attributes Create a report with the data set’s X X X
creation date, location, number of
observations, variable names, labels,
types, and formats.
Random Sample Create an output data set that X X X
contains a random sample of the rows
in the input data set.
Rank Compute ranks for numeric variables X X X
across the observations of a SAS data
set and send the ranks as output to a
new SAS data set.
Sort Data Sort a data source by any of its X X X
columns.
Standardize Data Create an output data set by X X X
standardizing the variables in a data
source to a given mean and standard
deviation.
Split Columns Create an output data set by splitting X X X
the unique combination of values of the
selected columns in the input data set
into multiple columns.
Stack Columns Create an output data set by X X X
restructuring selected columns in the
input data set so that these columns
are transposed into observations.
Transpose a Set of Turn the selected columns of a data X X X
Data source into the rows of an output data
set.
Describe Category
List Report Wizard Create detail or summary reports. X X X
Distribution Create a data summary with X X X
Analysis distribution information for numeric
variables. Used to create plots.
Characterize Data Create a summary report with graphs X X X
of frequency and univariate statistics
for SAS data sets.
List Data Print the observations in a SAS data X X X

set, using all or some of the variables,
from a variety of reports.
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Capability

Description

Role

Advanced

OLAP

Analysis

One-Way
Frequencies

Summary Statistics

Summary Tables

Table Analysis

Generate frequency tables or perform
binomial and chi-square tests.

Compute descriptive statistics for
variables across all or groups of
observations, or summarize data in a
graphical display.

Display descriptive statistics for
selected variables in a variety of tables.

Generate crosstabulation tables, also
known as contingency tables.

X

X

Graph Category
Contour Plot

Bubble Plot

Radar Chart

Box Plot

Donut Chart

Area Plot

Pie Chart

Line Plot

Bar Chart

Create Map Feature
Table

Surface Plot

Create line, filled, pattern, or smooth
plots that show the mathematical
relationships between three numeric
variables.

Create a bubble plot that displays up
to five dimensions (X, Y, size, color, and
time).

Create radar or star charts that show
the relative frequency of data
measures.

Create box plots, hi-lo charts, or
hi-lo-close charts that display multiple
summary statistics for a numeric
variable across the values of a chart
variable.

Create simple or group charts that
show the relative contribution of the
parts to the whole.

Create area, spline, step, or overlay
plots.

Create simple or group charts that
show the relative contribution of the
parts to the whole.

Create line, scatter, spline, needle,
step, regression, smooth, STD,
Lagrange interpolation, or overlay
plots.

Create vertical, horizontal, or
three-dimensional bar charts.

Create a feature table for map data
sets and convert spherical coordinates
to Cartesian coordinates.

Create three-dimensional wireframe
plots, smooth plots, or gradient plots.
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Role
Capability Description Advanced OLAP Analysis
Map Graph Create a two-dimensional (choropleth) X X X
or three-dimensional (block and prism)
color map that shows the variation in
the value of a response variable for
different geographical areas.
Bar-Line Chart Create a vertical bar chart with a line X X X
plot overlay. The line plot represents
the value of a statistic that is
calculated for a variable.
Scatter Plot Create two-dimensional scatter plots, X X X
three-dimensional scatter plots, or
three-dimensional needle plots.
ANOVA Category
Linear Models Analyze data using the least squares to X X X
fit general linear models.
Mixed Models Fit a variety of mixed linear models to X X X
data and use these fitted models to
make statistical inferences about the
data.
Nonparametric Run nonparametric tests for location. X X X
One-Way ANOVA The task also scales differences across
a one-way classification and provides a
standard analysis of variance on the
raw data.
One-Way ANOVA Test for differences among the means X X X
of the levels and quantify these
differences.
t Test Perform t-tests for one sample, two X X X
samples, and paired observations.
Regression
Category
Generalized Linear Model data that is not normally X X X
Models distributed. Also model data for which
the mean has been restricted to a
range of values. Also model data for
which the variance is not constant.
Linear Regression Perform linear regression analysis on X X X
multiple dependent and independent
variables.
Logistic Regression Investigate the relationship between X X X
discrete responses and a set of
explanatory variables.
Nonlinear Produce least squares or weighted X X X
Regression least squares estimates of the

parameters of a nonlinear model.
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Role
Capability Description Advanced OLAP Analysis
Multivariate
Category
Canonical Examine the relationship between X X X
Correlation linear combinations of X and Y
variables.
Cluster Analysis Create hierarchical clusters of X X X
coordinate data or distance data.
Correlations Determine the relationship between X X X
numeric variables by calculating
correlation coefficients.
Discriminant Develop a discriminant criterion that X X X
Analysis can be used to classify variables into
the groups defined by the classification
variable.
Factor Analysis Perform a variety of common factor X X X
and component analyses and rotations.
Principal Examine relationships among several X X X
Components variables. This task can be used for
summarizing data and detecting linear
relationships.
Survival Analysis
Category
Life Tables Compute nonparametric estimates of X X X
the survival distribution of data that
may be right-censored due either to
withdrawals or to termination of the
study.
Proportional Perform regression analysis of survival X X X
Hazards data based on the Cox proportional
hazards model.
Capability
Category
CDF Plots Plot the observed cumulative X
distribution function (CDF) of a
variable.
Histograms Compare the distribution of X
measurements from a process in
statistical control to its specification
limits.
Q-Q Plots Compare ordered values of a variable X

to the quantiles of a specified
theoretical distribution, such as the
normal distribution.
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Role
Capability Description Advanced OLAP Analysis
Probability Plots Compare ordered values of a variable X
to the percentiles of a specified
theoretical distribution, such as the
normal distribution.
P-P Plots Compare the empirical cumulative X
distribution function (ECDF) of a
variable to a specified theoretical
cumulative distribution function, such
as the normal distribution.
Control Charts
Category
Box Chart Create a mean chart for the subgroup X X X
means. The task superimposes the
box-and-whisker plots of the
measurements for each subgroup onto
the mean chart.
¢ Chart Create c charts for the numbers of X X X
nonconformities (defects) in the
subgroup samples.
Individual Create control charts for the individual X X X
Measurements measurements and the moving ranges.
Chart
np Chart Create np charts for the numbers of X X X
nonconformities (defects) in the
subgroup samples.
p Chart Create p charts for the proportions of X X X
nonconforming (defective) items in the
subgroup samples.
u Chart Create u charts for the numbers of X X X
nonconformities (defects) per inspection
unit in the subgroup samples that
contain arbitrary numbers of units.
Mean and Range Create mean and range charts for the X X X
Chart subgroup means and the subgroup
ranges.
Mean and Standard Create mean and standard deviation X X X
Deviation Chart charts for the subgroup means and the
subgroup standard deviations.
Pareto Category
Pareto Chart Create a chart that displays the X

relative frequency of problems in a
process as bars. Pareto charts help the
user identify the problems that deserve
the most attention.
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Role

Capability Description Advanced OLAP Analysis
Time Series
Category
Forecast Studio Specify the forecasting variables, X X X
Create Project choose whether to forecast your data

hierarchically, and specify the forecast

horizon for a new SAS Forecast Studio

project.
Forecast Studio Open the selected series from an X X X
Open Project existing SAS Forecast Studio project

and specify how to display the results.
Forecast Studio Submit overrides for the forecast data X X X
Override Project in an existing SAS Forecast Studio

project.
ARIMA Modeling Analyze and forecast equally spaced X X X
and Forecasting univariate time series data, transfer

function data, and intervention data by

using the ARIMA or ARMA model.
Regression Analysis Estimate and forecast linear regression X X X
with Autoregressive models for time series data when the
Errors errors are not independent through

time or the error variance is not

constant.
Basic Forecasting Generate forecasts for many time X X X

series in one step. This task uses

extrapolative forecasting methods

where the forecasts for a series are

functions only of time and past values.
Regression Analysis Analyze panel data sets that consist of X X X
of Panel Data time series observations on each of

several cross-sectional units. The task

uses a class of linear econometric

models to analyze the data.
Prepare Time Series  Prepare data for analysis by time X X X
Data series tasks or other tasks.
Create Time Series Convert transactional data into X X X
Data fixed-interval time series.

Transactional data is time-stamped

data that is collected over time with

irregular or varied frequency.
Model Scoring
Category
Model Scoring Score a data set against an existing X X X

SAS Enterprise Miner predictive
model.
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Role
Capability Description Advanced OLAP Analysis
SAS Management
Console 9.2
Category

Access Unregistered  Access plug-ins that are not registered X
Plug-ins in metadata.

Registering Custom Tasks as Capabhilities in the SAS Add-In for
Microsoft Office

Overview

Custom add-in tasks are .NET assemblies (DLL files) that you create, deploy,
register, and execute from the SAS ribbon in Microsoft Office applications.

To provide access to custom tasks based on the job responsibilities in your
organization, you first register custom tasks as capabilities. You then assign the
capabilities to roles, and assign users to roles.

The process of creating, deploying, registering, and executing custom tasks as

capabilities in the SAS Add-In for Microsoft Office is similar to the process that is used

in SAS Enterprise Guide.

Create Custom Tasks

To create custom tasks, you develop Windows executables and package them as .NET

assemblies. It is convenient to assemble multiple tasks in a single .NET assembly so

that you can share code and implementation among the tasks. For additional

information, see Administering SAS Enterprise Guide, at
http://support.sas.com/documentation/onlinedoc/guide/.

Deploy Custom Tasks

You can deploy custom tasks to computers that run the SAS Add-In for Microsoft
Office in two ways, using drop-in deployment or add-in deployment. Drop-in

deployment copies .NET assemblies into specific local directories that are recognized by

the SAS Add-In for Microsoft Office. Custom tasks in drop-in directories are

automatically registered (made available for execution) the next time the user starts a

Microsoft Office application.

Add-in deployment copies .NET assemblies into any local directory. You then identify

those directories for use in the SAS Add-In for Microsoft Office using the Add-In
Manager in SAS Enterprise Guide. Deployment registration makes the custom tasks
available for execution from the SAS ribbon in Microsoft Office applications.

When you deploy your custom tasks, make sure that you include any dependent

assemblies that are referenced by those tasks. At the same time, make sure that you do

not include any dependent assemblies that are provided by the SAS Add-In for
Microsoft Office or by SAS Enterprise Guide.
Follow these steps to use the Add-In Manager:



20 Register Custom Tasks As Capabilities A Chapter 3

1

2

Copy the .NET assembly into one of the following directories:

O C:\ProgramFiles\SAS\Add-InForMicrosoftOffice\release-
number\Custom

0 %appdata%\SAS\Add-InForMicrosoftOffice\release-number\Custom
%appdata% is the Microsoft Window environment variable that maps to a
user account. Repeat the copy in other user accounts if multiple users run
the SAS Add-In for Microsoft Office on the same host.

O %appdata%\SAS\SharedSettings\release-number\Custom
Use this location to deploy custom tasks to specified user accounts, using a
shared directory that is accessed by the SAS Add-In for Microsoft Office and
SAS Enterprise Guide.

Start or restart a Microsoft Office application to register the custom tasks and
make them available for testing.

Follow these steps to use add-in deployment:

1
2

~N o o AW

Copy the .NET assembly into any local directory.

Start SAS Enterprise Guide and open the Add-In Manager. Select Tools » Add-In
» Add-In Manager.

In the Add-In Manager dialog box, select Browse .

Navigate to the directory where you stored your .NET assembly.

Click open to display the names of the custom tasks in the assembly.

Click OK to accept the custom tasks and register them in SAS Enterprise Guide.
Test the new custom tasks in a Microsoft Office application.

Register Custom Tasks As Capabhilities

After you deploy custom tasks, follow these steps to register custom tasks as
capabilities:

1

In SAS Enterprise Guide, start SAS Enterprise Guide Explorer. Select Tools »
SAS Enterprise Guide Explorer.

In Explorer, select Tools » Task Import Wizard.

In the first page of the Task Import Wizard, you see your current metadata profile
connection. If you need to connect with a different profile, click cancel to close the
wizard and select File » Manage Profiles. After you change your profile, click
Close, then start the Task Import Wizard.

In the second page of the Task Import Wizard, specify the location from which you
want to import task definitions. You can choose to have the wizard search
standard locations for task definitions or you can specify a task-definition XML file.

Select tasks to receive metadata, and then click Finish in the sixth wizard page to
create metadata.

If you are unable to create metadata, then you might need to install the package
named SAS Add-In for Microsoft Office Server Data on the host that contains your
current metadata repository.

Apply Custom-Task Capabilities to Roles

Follow these steps to apply custom-task capabilities to roles:

1

In SAS Management Console, open the User Manager.
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2 To create a new role for your custom-task capabilities, right-click in the User
Manager and select New » Role.

3 To add a custom-task capability to an existing role, double-click an Add-In for
Microsoft Office role.

In the role properties window, click the capabilities tab.

Click the custom-task capabilities that you want to add to that role.

4
5 In the capabilities tab, expand the Plug-Ins branch in the tree view.
6
7 Click ok.

The custom-task capabilities will be applied to the role the next time affected users
initialize a Microsoft Office application.

Note: To access unregistered custom tasks, you need the capability Access
Unregistered Custom Tasks, which is available in the Tools and Help category, as
described in “Default Roles and Capabilities for the SAS Add-In for Microsoft Office” on
page 11. A

Library Access for the SAS Add-In for Microsoft Office

If the add-in attempts to write data to a table on the SAS Metadata Server, and the
structure of the updated table is different, the metadata is not updated. For this
reason, it is advisable to regulate Write access to registered tables from Excel, Word,
and PowerPoint. Read access, for the purposes of querying SAS OLAP cubes using
Excel, requires no special consideration.

Access to registered libraries is determined in part by the library access method. By
default, all libraries that are registered on the SAS Metadata Server are Read-only.
SAS Add-In for Microsoft Office users cannot create, add, or delete tables. The default
library access method can be changed, as described in “Review Library Access in SAS
Enterprise Guide” on page 45.

CAUTION:
To maintain referential integrity on the SAS Metadata Server, it is advisable to inform the
SAS Add-In for Microsoft Office users about their permissions to access registered
libraries. ~
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Overview of Administering SAS Data Integration Studio

SAS Data Integration Studio is a visual design tool that enables data integration
specialists to consolidate and manage enterprise data from a variety of source systems,
applications, and technologies. This software enables these users to create process flows
that accomplish the following tasks:

O extract, transform, and load (ETL) data for use in data warehouses and data marts

O cleanse, migrate, synchronize, replicate, and promote data for applications and

business services

SAS Data Integration Studio enables users to integrate information from any platform
that is accessible to SAS and from any format that is accessible to SAS.

The following table introduces the administrative tasks that are associated with SAS
Data Integration Studio:

Table 4.1 Administrative Tasks for SAS Data Integration Studio

Administrative Task Purpose of Task

Connect to SAS servers Make sure that your data integration specialists
can connect to the necessary SAS servers. For
example, each user must be able to connect to
the SAS Metadata Server to register data
sources and other objects.

Connect to data servers Make sure that your data integration specialists
can connect to the necessary data servers.

Set up change management Set up a change-managed folder in the Folders
tree, if desired. This enables individual users to
check objects out of a foundation repository and
place them in a private repository. The private
repository, called a project repository, provides a
location where the users can test changes.

Set up multi-tier environments Set up SAS Data Integration Studio to work in a
multi-tier configuration. Almost all
configurations have multiple tiers.

Administer message queues Install third-party message queue software,
define queues, and register queues for
inter-process communication.
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Administrative Task

Purpose of Task

Configure stored process servers for the
deployment of stored process jobs or Web service
jobs

Configure the SAS Workspace Server to enable
the bulk loading of data

Test the Platform Computing Scheduling Server

Set up the SAS Data Quality Server software

Redirect output and logging information to a file

Configure status code handling

Use FTP or HTTP servers to access external files

Install SAS Stored Process Servers as needed for
jobs that are deployed as stored processes or
Web services that generate XML output.

Enable SAS Workspace Servers to execute

external commands so that jobs can rapidly load
data into a DBMS.

Test the servers (and clients) that enable your
users to schedule sets of SAS Data Integration
Studio jobs.

Set up the infrastructure necessary for your
users to use data-quality transformations.

Specify alternative destinations for the SAS log
and SAS output.

Configure jobs to send status codes via e-mail, to
files, or by executing a SAS program.

Install a content server to access external files.

Connecting to SAS Servers

Overview of SAS Server Connections in SAS Data Integration Studio

SAS Data Integration Studio users connect to a SAS Metadata Server and a SAS
Workspace Server. The SAS Workspace Server might be part of a load-balancing grid

configuration.

Connect to a SAS Metadata Server

At initialization time, SAS Data Integration Studio users select a connection profile

that connects the desktop application to a SAS Metadata Server. The administrator
might need to help users create one or more connection profiles, as described in
“Administering Connection Profiles for Desktop Applications” on page 4.

Connect to a Workspace Server

When you execute a job in SAS Data Integration Studio, the application submits
generated SAS code to a SAS Workspace Server, which executes the code. Therefore, it
is imperative that an object spawner is running and that SAS Data Integration Studio
is able to use the spawner to start a SAS Workspace Server. To test a connection to a
SAS Workspace Server, follow these steps:

1 Select Tools » Options.

2 In the Options dialog box, select the Server tab.

3 Select from the list the name of the SAS Application Server to which the SAS
Workspace Server belongs.

4 Click Test Connection. You might be prompted for a user name and password. If
you are, enter credentials that enable you to be authenticated on the host where
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the SAS Workspace Server is running. If all goes well, you see an Information
dialog box that says, “Connection to the server was successful”.

Set Grid Server Options

Grid computing is implemented in the separately licensed SAS Grid Manager
software. SAS Grid Manager runs grid-enabled jobs on multiple servers. The grid
configuration consists of a logical SAS grid server that distributes processing tasks. In
addition, the configuration includes any number of SAS Workspace Servers that execute
distributed tasks, a SAS Grid Monitor server, and a Grid Monitor plug-in for SAS
Management Console. The distribution of tasks across the grid is determined by a grid
workload specification that you create and register in SAS Management Console.

The following steps are performed on the global options tab in SAS Data
Integration Studio. Before you can perform these tasks, a SAS grid server and a grid
workload specification must be registered in SAS Management Console. For more
information about these tasks, see Grid Computing in SAS.

To select a SAS grid server and specify related options for SAS Data Integration
Studio jobs, follow these steps:

1 In SAS Data Integration Studio, select Tools » Options from the menu bar and
select the SAS Server tab.

2 In the 6rid workload specification box, select the specification that you want
to apply to your grid jobs.

3 In the signon options box, specify the options that you want to apply at the
start of each grid computing session.

4 In the Number of signon entries box, enter the number of times that you want
to reconnect to the grid after errors. The default value is three.

5 Select the Code Generation tab.

6 Jobs executed on a grid are executed in parallel. SAS Data Integration Studio uses
a set of macros to enable parallel processing. To enable parallel processing for all
new jobs, select the Enable parallel processing macros check box.

Alternatively, you can enable these macros for individual jobs. You can select
YES in the Enable parallel processing macros option on the options tab of
the properties window for an individual job. Also, simply including a Loop
transformation in a job enables parallel processing for that job.
7 Consider setting options for concurrent processes based on the hosts that make up
your grid.
8 Click oK to save your changes.

Connecting to Data Servers

Establish that your users can connect to the SAS Metadata Server and the system’s
SAS Workspace Servers. Then ensure that users can access the input data sources to
SAS Data Integration Studio jobs. Here are some examples of these sources:

DB2 tables

Sybase tables
Teradata tables
ODBC data sources
Oracle tables

O
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O SAS data sets
0 SAS Scalable Performance Data Engine tables

The general procedure follows these steps:

0 Register your data sources (see the SAS Intelligence Platform: Data
Administration Guide).

O View data sources in SAS Data Integration Studio.

To determine whether your data integration developers are able to read data from a
particular data server, follow these steps:

1 In the Inventory tree, expand the Table node.

2 Right-click a data source and select Open to display the View Data window.

About Scheduling Servers

Data integration specialists can create flows, which are sets of jobs that have been
deployed for scheduling. Each job within a flow can be scheduled to execute as follows:

O at a certain time
O as determined by the state of a file (existence, age, or content)
O as determined by the state of a job or flow (completion)

For information about installing, testing and using scheduling services, refer to
Scheduling in SAS.

Setting up Change Management

Overview of Change Management

The change management feature enables a team of SAS Data Integration Studio
users to work simultaneously with a set of related metadata and avoid overwriting each
other’s changes. With change management, most users are restricted from adding or
updating the metadata in a change-managed folder in the Folders tree. Authorized
users, however, can add new metadata objects and check them in to the
change-managed folder. They can also check out metadata objects from the
change-managed folder in order to update them. The objects are locked so that no one
else can update them as long as the objects are checked out. When the users are ready,
they check in the objects to the change-managed folder, and the lock is released.

If a user is authorized to work in a change-managed folder, a Checkouts tree is added
to his or her desktop in SAS Data Integration Studio. The Checkouts tree displays
metadata in the user’s project repository, which is an individual work area or play pen.
Typically, each user has his or her own project repository. If more than one user were to
connect to the same project repository, the users might overwrite each other’s changes.

To set up change management, follow these steps:

1 Register SAS Data Integration Studio users on the metadata server if they are not
registered already. For more information, see Chapter 8, “Administering SAS
Management Console,” on page 65.

2 (Optional) Create a custom group and add the SAS Data Integration Studio users

who are working with change management as members of this group. For
example, you could create a group called Change Management Group. For more
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information, see Chapter 8, “Administering SAS Management Console,” on page
65. Creating this custom group makes it easier to specify metadata permissions
for the change-managed folder. You can specify permissions for the change
management group rather than individual users.

Create a change-managed folder in the Folders tree. For more information, see the
next section.

4 Create a folder structure for project repositories on the file system.

5 Create a project repository for each user who works in the change-managed folder.

6 Have each user create a connection profile, connect to the metadata server, and

select his or her project repository. To verify that change management is working,
you might want to have each user check out a metadata object and check it

in. For more information about these tasks, see “Administering Connection
Profiles for Desktop Applications” on page 4.

Create a Change-Managed Folder in the Folders Tree

Follow these steps to add a new folder in the Folders tree. Specify a special set of
metadata permissions for that folder. This task is easier if you have already created a
custom group and added the SAS Data Integration Studio users who work with change
management as members of this group.

1

In SAS Management Console, right-click a parent folder in the Folders tree, such
as SAS Folders, and select New Folder.

Specify a name for the new folder and click Finish to add the folder to the Folders
tree.

3 Right-click the new folder and select Properties.

4 In the properties window, click the Authorization tab.

5 For users or groups who should not be authorized to work in the new folder, grant

ReadMetadata permission, and deny other permissions.

For users or groups who should be authorized to work in the new folder, grant
ReadMetadata and CheckInMetadata permissions, and deny other permissions.

The standard set of privileges that enable you to work in a change-managed folder
do not enable you to perform administrative tasks such as the following:

O

deploy a job for scheduling
0 deploy a job as a stored process
O create a Web service from a stored process
O clear a project repository that you do not own
For administrators who need to perform these tasks, grant WriteMetadata and
WriteMemberMetadata permissions.

When you are finished specifying permissions, click OK to save your changes to
the Authorization tab.

You have now created a change-managed folder in the Folders tree.

Create a Folder Structure for Project Repositories on the File System

On the computer where the SAS Metadata Server is installed, create a folder
structure for project repositories on the file system.

Each sub-folder under Projects contains the project repository for a user who is
working with change management in SAS Data Integration Studio.
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To create a folder structure for project repositories on the file system, follow these
steps:

1 On the computer where the SAS Metadata Server is installed, go to the folder
SAS-installation-
directory\Levl\SASMeta\MetadataServer\MetadataRepositories.

2 In the MetadataRepositories folder, a folder for the foundation repository is
displayed. On the same level as the foundation folder, add a new folder called
Projects.

3 Under the Projects folder, create a folder for each user who works with change
management in SAS Data Integration Studio.

You are now ready to create project repositories for each user.

Create a Project Repository for Each User

Repeat these steps for each user who works in a change-managed folder. It is
assumed that you have registered these users and have created an appropriate folder
structure for project repositories.

1 In SAS Management Console, expand the Metadata Manager folder, and then
expand the Active Server folder.

2 Right-click the Project Repositories folder and select New Project
Repository.

3 In the Create New Project Repository Wizard, select a SAS Data Integration
Studio user who works in a change-managed folder. Click Next.

4 Enter a name and an optional description of the project repository. Click Next.

5 Specify the full physical path to a project repository folder. Typically you make no
other changes. Click Next.

6 On the last page of the wizard, click Finish.

An icon that represents the new repository is displayed under the Project
Repositories folder.

After you create a project repository for a user, ask that user to create a connection
profile. Use that profile to connect to a SAS Metadata Server, and select his or her
project repository. You might have each user check out a metadata object and check it
back in. This verifies that change management is operational.

Setting Up Multi-Tier Environments

Access Remote Data

Overview of Remote Data Access

The procedures in this section explain how to enable your SAS Data Integration
Studio users to access data on a host that is remote from the SAS Workspace Server.
This is done by installing SAS/CONNECT software on the SAS Workspace Server host
and then configuring a SAS/CONNECT server on the remote-data host.

In order to access data on a host that is remote from your SAS Workspace Server,
you must run SAS/CONNECT software. Run SAS/CONNECT on your SAS Workspace
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Server machine (the local host), and on the machine with your data (the remote host).
To understand this setup, consider the following figure:

Workspace Server
Metadata Server

Local Host

T
- SAS/CONNECT Client
- Object Spawner

SAS Data
Integration
Studio Client

Data

Remote Host

- SAS/CONNECT Server
- SAS/CONNECT Spawner

In this network, we have three machines:

O the machine running the SAS Workspace Server and the SAS Metadata Server
(the local host)

O a separate machine with data (the remote host)
o0 the SAS Data Integration Studio client machine

Set Up a Local Host

These procedures assume that SAS software has been installed on the local host
machine. Furthermore, the local host machine needs to be set up as follows:

0 The local host runs the SAS Workspace Server.

0 The SAS Application Server of which the SAS Workspace Server is a component
needs to be set as the default SAS Application Server for SAS Data Integration
Studio. This is done from the SAS Data Integration Studio client machine. See
“Connect to a Workspace Server” on page 25.

0o SAS/CONNECT software needs to be installed on the local host machine. This
should have been done at installation time.

Set Up a Remote Host

Install and configure Base SAS and SAS/CONNECT software on the remote host.
Follow the instructions in the SAS Intelligence Platform: Installation and Configuration
Guide.

The installation process creates the server initialization script ConnectServer.bat.
Use this script to invoke the SAS/CONNECT spawner as a service. The spawner starts
SAS/CONNECT sessions as needed. You can find the files in the

SAS-installation-directory\Levl\appServer\ConnectServer.
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You can make other configuration changes to the remote host from any machine
running SAS Management Console.

In the next two sections, you define the SAS/CONNECT server and your SAS library
in metadata.

Set Up a Remote SAS/CONNECT Server

On the remote host, use the SAS Deployment Wizard to define a second and new SAS
Application Server that contains a SAS/CONNECT server and a SAS Workspace Server.
The new servers are necessary because the local SAS Application Server does not have
access to the remote library. For information about using the SAS Deployment Wizard
to create new a SAS Application Server, see the SAS Intelligence Platform: Application
Server Administration Guide.

Define SAS Libraries

From SAS Management Console, define one or more SAS libraries on the remote host
machine. The libraries contain the tables that are accessed by SAS Data Integration
Studio. These instructions are appropriate for SAS data sets:

1 Expand Data Library Manager.
2 Right-click Libraries and select New Library.

3 Use the New Library Wizard to define the library. Assign the new library to the
new SAS Application Server on the remote host.

Set Up a SAS Data Integration Studio Client Machine

From the SAS Data Integration Studio client machine, you need to do the following:
1 define a default SAS Application Server
2 define tables in the metadata for the remote host
3 test your setup
In addition, if you have created a new authentication domain for your remote server,

you need to create new logins for your SAS Data Integration Studio users. These logins
must contain a user ID and password that are valid on the SAS/CONNECT host.

Register Source Tables on the Remote Host

To identify in metadata the tables on the remote host, follow these steps:

In SAS Data Integration Studio, select File » Register Tables.

In the sources folder, select a source, such as sAs, and click Next.
In the sAs Library box, select the library that you created earlier.
Verify or edit the library details.
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Consider selecting the DBMS check boxes to enable case-sensitivity or special
characters for the source tables, and then click Next.

D

Select the tables to register in metadata and click Next.
7 Review your entries, and then click Finish.

Test Your Setup Using View Data

To test your setup, follow these steps:
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1 In SAS Data Integration Studio, select the Inventory tab.
2 In the Inventory tab, expand the Library node.
3 Right-click a table in the library and select view Data.

This test verifies that you can access your remote library.

Process Remote Johs

Overview of Remote Job Processing

You might want to process one or more SAS Data Integration Studio jobs. There
might be a large amount of data on a remote machine to which you save your results.
In such an instance, it might be more efficient to move the job itself to the remote
machine. A multi-tiered configuration can make that possible.

Metadata Server

Local Host
SAS Data
Integration
Studio Client
Data

Workspace Server
Batch Server
Deployment Directory

Remote Host

- SAS Integration Technologies

To move a job to a remote machine, you need to have a SAS Workspace Server on the
remote host. The following software must be installed on the remote host machine:

O Base SAS software

o0 SAS Integration Technologies software
If you have not already installed this software, follow the instructions in the SAS
Intelligence Platform: Installation and Configuration Guide. After installation, run the
SAS Deployment Wizard to configure the following:

0 SAS object spawner

0 SAS Workspace Server

0o SAS DATA step batch server

Select Your Application Server and Workspace Server

To run SAS Data Integration Studio jobs on a remote host, open SAS Data
Integration Studio and select Tools » Options » SAS Server. Select the remote SAS
Application Server, and then click OK.
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Register Your Batch Job Deployment Directory

Batch jobs run through the Platform Scheduler, as configured through the Schedule
Manager.
To register the directory for your batch jobs, follow these steps:

1
2

Create the directory on the specified host.

In SAS Management Console, expand the Schedule Manager and select
Deployment Directories.

3 With the name of the new SAS Application Server selected, select New.

4 In the New Directory window, enter a directory name and path, and then click Ok.

Deploy a Job Remotely Using SAS Data Integration Studio

To test your remote job setup, follow these steps:

1
2
3
4

5

Start SAS Data Integration Studio.
In the Inventory tab, expand Jobs.
Right-click the job you that want to deploy and select Scheduling » Deploy.

In the Deploy a job for scheduling window, select a batch server and change the
name, deployment directory, and job location, as necessary.

Click ok to deploy the job.

The deployed code is automatically copied to the remote host and is ready for
scheduling or running at any time.

Set up for HP Neoview Tables and Netezza Tables

To access HP Neoview tables or Netezza tables in SAS Data Integration Studio,
administrators must first register the appropriate servers and libraries. Before
registering servers and libraries for Neoview or Netezza, administrators must add
resource templates for these databases.

To add resource templates for Neoview and Netezza, follow these steps once per
metadata server. Repeat for all metadata servers that SAS Data Integration Studio
users access.

1
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Open SAS Management Console.

In the Repository box, select Foundation.

In the Plugins tab, expand the Metadata Manager.

Right-click the Resource Templates folder and select Add Resource Template.
In the Add Resource Template Wizard, select Custom, and then click Next.

To find the folder that contains the resource templates for HP Neoview and
Netezza, click Add. A window displays the file system where SAS Management
Console 9.2 is installed.

Navigate to the folder where SAS Management Console 9.2 is installed. Expand
that folder, and then expand the 9.2 subfolder.

In the 9.2 subfolder, expand the Resource Templates subfolder. You should see
the following templates: Neoview_Library.zip, Neoview_Server.zip,
Netezza_Library.zip, and Netezza_Server.zip. Install both the library template and
the server template for each new database that you want to access.

Select a template (such as Neoview_Library.zip) and click ok. The template is
added to the window in the wizard. Repeat Steps 6, 7, and 8 for each template
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that you want to add. When all of the desired templates have been added to the
window, click Next.

10 Review the templates to be installed, and then click Finish. The templates are
installed in the Resource Templates folder in SAS Management Console.

Administering Message Queues

What Are Message Queues?

Message queues are collections of data objects that enable asynchronous
communication between processes. One application writes a message to a queue.
Another application reads messages from the queue to begin the next step in a process.
Verification processes guarantee that all messages are transmitted without error.

Queue managers handle message transmission and verification.

About the Third-Party Messaging Software

Fundamental message queue technology is provided in the following third—party
software:

O Microsoft MSMQ

o IBM WebSphere MQ

You need to install and configure at least one messaging software application before you
register metadata and run SAS messaging jobs.

About Message Queues in the SAS Intelligence Platform

In the SAS Intelligence Platform, you register metadata for queues and queue
managers by using SAS Management Console after you install and configure
third-party messaging software.

After you register metadata, you use the following transformations to create
messaging jobs in SAS Data Integration Studio:

O Microsoft Queue Reader

O Microsoft Queue Writer

o WebSphere Queue Reader

o WebSphere Queue Writer
SAS Data Integration Studio also enables impact analysis and reverse impact analysis
on queues, which you can use to track data flow into and out of queues.

The following data can be written to message queues using the queue writer
transformation:

O text of length up to 32,767 bytes
0 rows from SAS tables, one row per message

O external files

The queue reader transformation can be configured to read a specified number of
rows from the message queue.
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Requirements for Message Queues

To implement message queuing, you need to install and configure Microsoft MSMQ
or WebSphere MQ. Start the installation process by downloading and installing
third-party software on specified SAS Application Servers. In general you can plan to
install a queue manager on each host that runs a SAS Workspace Server that runs
message queue jobs. If you choose WebSphere MQ, you can install queue managers on
hosts other than SAS Workspace Servers.

Install and Configure the Microsoft MSMQ Message Queue Software

To install the MSMQ software on a SAS Workspace Server host that runs message
queue jobs, follow these steps:
1 Ensure that the host meets the requirements for message queues, as described in
“Requirements for Message Queues” on page 35.
2 In Windows, select Add or Remove Programs.

3 In the shortcut bar of the Add or Remove Programs window, select Add or Remove
Windows Components, which opens the Windows Components Wizard.

4 In the Windows Components Wizard, select the Message queuing check box and
click the petails button, which displays the Message queuing dialog box.

5 In the Message queuing dialog box, select all four subcomponent check boxes, and
then click OK to return to the Windows Components Wizard.

6 Click Next to install the MSMQ software, and then close the Windows
Components Wizard.

7 Use the MSMQ software to create the queues and queue managers that are
required on this particular host. You need to create at least one queue for each
queue manager. The same object names are used in SAS, so you might want to
include the host name as part of the object names.

8 Use the Microsoft MSMQ software to start the queue managers.

9 Use SAS Management Console to register metadata for queues and queue
managers, as described in Chapter 4, “Administering SAS Data Integration
Studio,” on page 23.

Install and Configure the IBM WebSphere MQ Message Queue Software

To install and configure the WebSphere MQ software, follow these steps:

1 Download the software and documentation. Start with the following Web site:
http://www-306.ibm.com/software/integration/wmg/index.html. Work with
installation representatives from IBM and SAS as needed. At minimum, you need
to install the WebSphere MQ Client software on all SAS Workspace Server hosts
that run message queue jobs. Make sure that you meet the requirements for
message queuing that are specified in “Administering Message Queues” on page 34.

Note that if you install only the WebSphere MQ Client software, then you need
to configure the environment variable MQSERVER to communicate with the
WebSphere MQ Server software.

2 Use the WebSphere MQ software to create queues and queue managers on their
respective hosts. For each queue manager that you need to define at least one
queue. For reference in SAS, you might want to include the machine name in the
names of the queue managers.
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3 Use the WebSphere MQ software to start the queue managers on their respective
hosts.

4 Use SAS Management Console to register metadata for queues and queue
managers, as described in the next section.

Create a Message Queue Polling Server for WehSphere MQ Message
Queue Software

If your site uses the WebSphere MQ (MQSeries) or WebSphere MQ Client (MQSeries
C) from IBM, you can use SAS Message Queue Polling Servers. The servers can
monitor message queues, manage messages, and trigger the execution of SAS programs
in response to messages. The implementation process involves the creation of a queue
manager, a queue polling server, a queue reader job, and a SAS program that interprets
messages. The implementation process is described in detail in Application Messaging
with SAS.

Create a Message Queue Server and Register Queues

To register metadata for a queue and a queue manager, follow these steps:
1 In SAS Management Console, right-click Server Manager and select New Server.

2 In the New Server Manager, under Queue Managers, select either MSMQ Queue
Manager or WebSphere Queue Manager and click Next.

3 Enter the exact name as it is defined in the third-party messaging software for the
new queue manager. The names are case-sensitive.

4 Enter a description, and then click Next.
5 Select queues and folders, and then click Next.

6 Specify an authentication domain, identify the host, and accept the default port
number of 1414.

7 Click Next, review your entries, and click Finish.
Be sure to register metadata for all of the queues and queue managers that are used
in SAS jobs.

To begin running messaging jobs, make sure that the queue managers are running
on their respective hosts.

Manage Queues and Queue Managers

To modify the metadata definitions of queues and queue managers, use the New
Server Wizard in SAS Management Console to delete the existing definitions and create
new definitions.

Before you delete metadata, you might want to run impact analysis and reverse
impact analysis to see the jobs that include the queues. To run impact analysis or
reverse impact analysis, follow these steps:

1 In SAS Data Integration Technologies, click the Inventory tab and expand
Message Queues.

2 Right-click a message queue and select Analyze.

3 In the Analysis window, examine the graphical displays of impact analysis and
reverse impact analysis to see how the message queue is used in existing jobs.
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You can delete the message queue if the analysis diagrams show no connections to
existing jobs or other metadata objects. If the diagrams show connections, edit or
remove the metadata objects before you delete the message queue.

To delete metadata for queues and queue managers, right-click the object in the
Server Manager of SAS Management Console and select Delete. Use the third-party
software to delete the physical queue objects.

Set ALLOWXCMD to Enable Bulk Loading or to Run UNIX Scripts

Set the ALLOWXCMD option as follows on your SAS Workspace Server or SAS
Batch Server so that your jobs can use the bulk-loading capabilities of the native DBMS
software. Also set the ALLOWXCMD option so that your jobs can run shell or PERL
scripts in UNIX.

1 In SAS Management Console, expand the Server Manager.
Right-click the SAS Workspace Server and select Properties.
In the Properties dialog box, click the options tab.

2

3

4 In the options tab, click Advanced Options.

5 In the Advanced Options tab, click the Launch Properties tab.
6 In the Launch Properties tab, select the Allow XCMD check box.
7

Click ok twice to save changes and close the Properties window.

All new sessions on that particular SAS Workspace Server will run with the option
ALLOWXCMD. Restart your current instance of SAS Data Integration Studio to run
jobs with the ALLOWXCMD option on that server.

Setting Up the SAS Data Quality Server Software

Overview of SAS Data Quality Server Software

When you run the SAS Deployment Wizard, you install the SAS Data Quality Server
software and configure a SAS Application Server to read a Quality Knowledge Base.
This enables data integration developers to use the data quality transformations Create
Match Code and Apply Lookup Standardization. Those developers can also make use of
the data quality functions that are provided in the Expression Builder, which is
available in many of the data integration transformations.

Enterprise implementations of the SAS Intelligence Platform make use of the
dfPower Studio software and DataFlux Integration Servers from DataFlux, a SAS
company. The dfPower Studio software enables you to customize your Quality
Knowledge Base. The dfPower Architect and dfPower Profile software enable you to
create jobs and real-time services that run on DataFlux Integration Servers. After you
register DataFlux Integration Servers in SAS metadata, you can write jobs in SAS Data
Integration Studio that execute DataFlux jobs and real-time services on the DataFlux
Integration Servers. The transformations that execute DataFlux jobs and real-time
services are called DataFlux IS Job and DataFlux IS Service.

This section explains the installed configuration of the SAS Data Quality Server
software, and how to perform a simple test to ensure that the system is working. This
section also covers several administrative tasks associated with data quality, including
the following:



38

About the Data Quality Configuration A Chapter 4

registering DataFlux Integration Servers

downloading new locales

creating new schemes

setting data quality options in SAS Data Integration Studio

O oo o

Note: If you are unfamiliar with the subject of data quality and the terminology
used in this section, see the SAS Data Quality Server: Reference. r

About the Data Quality Configuration

If the SAS Foundation software and the SAS Data Quality Server software are
installed, and the SAS Deployment Wizard has been run, this completes the setup.
Your data integration developers can use the data quality transformations and
functions. This automatic setup is convenient. However, you need to understand the
setup in case you need to make changes.

During installation, the SAS Data Quality Server software is installed in
..\dquality. A typical default path might be
SAS-configuration-directory\Levl\dquality.

Locales and schemes are located in directories subordinate to dquality:
sasmisc\content\locale and sasmisc\content\scheme.

A data quality configuration file is used to specify the location of the Quality
Knowledge Base. When you start a local interactive SAS session, the data quality
configuration is referenced by default at \dquality\sasmisc\dgsetup.txt.

When you use SAS Data Integration Studio to start a SAS Workspace server on a
SAS Application Server, the data quality configuration file is
SAS-configuration-directory\Levl\appServer\dgsetup.txt. A typical default
path is c:\SAS\EGServers\Lev1\SASApp\dgsetup.txt, where SASApp is the name of
the SAS Application Server.

On SAS Application Servers, the location of the data quality configuration file is
specified in the SAS configuration files
SAS-configuration-directory\Levl\appServer\sasv9.cfg and
sasv9_usermods.cfg. In the SAS configuration files, the line that specifies the location
of the setup file (by default) is as follows:

-dgsetuploc "dgsetup.txt"

In that same SAS configuration file, the server’s default data quality locale is
specified as:

-dglocale (ENUSA)

You can change values in the SAS configuration file sasv9_usermods.cfg without
restarting servers. Any SAS Data Integration Studio clients need to be restarted in
order to use new values.

Note: Do not edit sasv9.cfg, which needs to remain unchanged to retain default
settings. Instead, edit sasv9_usermods.cfg, which includes and overrides sasv9.cfg. A

You can use the Properties windows of the data quality transformations to override
the server defaults for data quality. You can also use the Data Quality tab of the
Options dialog box in SAS Data Integration Studio to override server defaults in
connection profiles. To display the Options dialog box, select Tools » Options.

Test the SAS Data Quality Server Software

To verify that your SAS Data Quality Server software is working, create a job in SAS
Data Integration Studio that contains a Create Match Code transformation.
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Follow these steps to create such a job:

1

From the SAS Data Integration Studio desktop, select Tools » Process Designer
to start the New Job Wizard.

In the New Job Wizard, enter a name for the job—such as Create Database Match
Codes—in the Name box. Then, click Finish. A new Process Designer window
appears on the right side of your workspace.

From the Process Library tree, select and drag the Create Match Code template
into the Process Designer.

From the Inventory tree, or another tree view, select and drag the metadata
object for any table to the source drop zone.

From the Inventory tree, or another tree view, select and drag the metadata
object for any table to the target drop zone. Both a Loader and the target table are
added to the graphical representation of the job.

Double-click the create Match Code transformation to display the Properties
menu.

As the Properties window appears, a dialog box indicates that match definitions
are being loaded from the Quality Knowledge Base. This indicates that the SAS
Data Quality Server software has been properly installed and configured.

To see a list of the match definitions that were loaded, specify a source table for
the job and display the Match Code tab of the Properties window. Double-click the
Match Definitions column to show the list of match definitions.

Register DataFlux Integration Servers

DataFlux Integration Servers run jobs and real-time services that are created with
the dfPower Architect and dfPower Profile software from DataFlux, a SAS company.
When you install a DataFlux Integration Server, and register the server in SAS
metadata, you can execute DataFlux jobs and service from other jobs that you create in
SAS Data Integration Studio.

To register a DataFlux Integration Server in SAS metadata, follow these steps:

1
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Open SAS Management Console, right-click the Server Manager, and select New
Server.

In the New Server Wizard, select Http server and click Next.
Enter a name and optional description and click Next.

Enter the optional server software version number and vendor name.
Select or enter the network path to the DataFlux Integration Server.

For the Application Server Type, select DataFlux Integration Server, and
then click Next.

Select authentication and protocol options.
Specify the name of the host.
Accept the default port number 21036.

10 Specify a proxy URL if one is needed.

11 Click Next, review your entries, and click Finish. The new server appears in the

Plug-Ins tab.

Download Locales

When initially installed, the Quality Knowledge Base contains a single locale
(English/USA). You can obtain additional locales from DataFlux, a SAS company, at the
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following Web address: http://www.dataflux.com/QKB. DataFlux regularly adds new
locales for various regions and national languages.

If you install additional locales, you need to update your data quality setup file
accordingly, as indicated in the documentation that is provided with each locale.
Information about locating and editing the setup file is also provided in SAS Data
Quality Server: Reference.

You can also create new locales (and edit existing ones) using the dfPower Customize
software from DataFlux, a SAS company.

Create Schemes

A scheme is a reusable collection of match codes and standardization values that is
applied to input character values for the purposes of transformation or analysis.
Schemes can be created in Blue Fusion Data (BFD) format or SAS format (NOBFD).
Before your data integration developers can use the Apply Lookup Standardization
template in SAS Data Integration Studio, you must specify a scheme repository and a
scheme repository type. You also need to create schemes by using the SAS Data Quality
Server or dfPower Studio software. For information about how to create schemes, see
the relevant product documentation.

Scheme repositories should be separated based on scheme type. BFD schemes and
NOBFD schemes should be stored separately to ensure that standardization jobs use
the appropriate schemes. Two scheme repositories are provided in the default
installation. On the SAS Application Server, the default scheme directory is
SAS-configuration-directory\Levl\appServer\SASEnvironment\QltyKB\scheme.
This directory contains a number of BFD schemes that are supplied with the SAS Data
Quality Server software.

A second default scheme directory is provided for interactive SAS sessions that are
started on the local host: ..\dquality\sasmisc\content\scheme.

In SAS Data Integration Studio, the scheme repository and the scheme repository
type are specified in the Data Quality tab of the Options dialog box (select Tools »
Options). The default scheme repository type is dfPower Scheme (BFD). No default
scheme repository is specified. When you specify a scheme repository in SAS Data
Integration Studio, a full or explicit path is recommended. Relative paths must be
specified relative to the SAS Application Server.

If you change an existing value in the Scheme Repository Type or Scheme
Repository box, then you need to replace any existing instances of the Apply Lookup
Standardization transformation. Replacement of the Scheme Repository Type or
Repository is required. The scheme metadata is added to these jobs when they are run
for the first time.

To update a job to use a different scheme repository:

1 Add a new Apply Lookup Standardization transformation to the job.
2 Configure the new transformation.

3 Delete the old transformation.

4 Move the new transformation into place.

Set Data Quality Options for SAS Data Integration Studio

You can set several options related to data quality by using the Data Quality tab in
the Options dialog box in SAS Data Integration Studio (select Tools » Options).
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Redirecting Output and Logging Information to a File

When you execute Data Integration Studio jobs, you generate and execute SAS code.
When you execute SAS code, you generate log information and perhaps other output. To
route the log information to a non-default location, set options on the SAS Workspace
Server that runs your jobs, as described in the logging chapter of SAS Intelligence
Platform: System Administration Guide.

To route other SAS output to a file, you can modify the start command of the SAS
Workspace Server, as follows:

1 In SAS Management Console, expand the Server Manager, and then expand the
node of the logical workspace server that is used by SAS Data Integration Studio
clients.

2 Right-click the icon for the physical SAS Workspace Server, and select Properties
from the pop-up menu.

3 In the Properties window, click the options tab.
4 Add the --print option in the Command text box, as follows:

sas -config "SAS--configuration-directory\Lev1\SASApp\sasv9_ usermods.cfg"
-print print-file-name.lst

5 Click oK in the Workspace Server Properties dialog box.

Enabling Status Code Handling

Overview of Status Code Handling

When a data integration developer executes a job in SAS Data Integration Studio,
notification of the job’s success or failure can be:

O e-mailed to a person.
O written to a file.

O cause the execution of an autocall macro.

A status Handling tab is included in the property windows for jobs and for some
transformations. Users can select options from a list of code conditions and actions on
this tab. For example, a user can select a code condition such as successful and
associate it with an action such as Send e-mail.

Before data integration developers can use some of the actions, you must set up the
environment properly. Such setup is required for the following actions:

0 E-mail actions: You must set SAS system options for mail for the SAS Application
Server that is used to execute jobs.

0 Custom actions: You must make a SAS macro autocall library accessible by the
SAS Application Server that is used to execute jobs.

0 Send Entry to a Data Set: You must pre-assign the library that contains the data
set to a SAS Application Server before the job or transformation executes.

For information about how to support the first two actions listed above, see the
following subsections. For information about libraries, see the “Assigning Libraries”
chapter of the SAS Intelligence Platform: Data Administration Guide.
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Support the E-mail Action

Setting up the E-mail action is simple. Just add the appropriate SAS system options
for e-mail to the configuration file ..\Levl\appServer\sasv9_usermods.cfg. For
example, if you are using the SMTP mail interface, you would add to this file the
following options:

-emailsys smtp
-emailhost email-server

In this case, the value of email-server specifies the SMTP server that supports mail
access for your site.

Note: The mail system options are documented in SAS Help and Documentation. A

Support the Custom Action

Using the Custom action, a data integration developer can execute a macro in a
macro autocall library in order to provide user-defined status handling for a job or
transformation. On the administrative side, all you need to do is to make sure that the
autocall library is known to the SAS Application Server. You do this by editing the file
. .\Levl\appServer\sasv9_usermods.cfg. By default, the file contains a line similar
to this:

-sasautos ("SASEnvironment/sasMacro" SASAUTOS)

Add the library to the list of libraries in parentheses. The path to the library can be a
full path or a path relative to ..\Levl\appServer.

Using FTP or HTTP Servers to Access External Files

External files are often stored on FTP or HTTP servers. To create a new FTP or
HTTP server, follow these steps:

1 In SAS Management Console, right-click the Server Manager and select New
Server.

2 In the New Server window, under Content Servers, select Ftp Server or Http
Server, and then click Next.

3 Specify a server name and click Next.

4 Specify a base path for the server. Add the software version and vendor to help
identify the server.

5 View and select the appropriate application server type, or accept the default value
(None).

6 Select the supports SOAP-Based Web Services check box if the new server
supports those services, and then click Next.

7 Enter authentication and host information. For more information about
authentication, see the SAS Intelligence Platform: Security Administration Guide.

8 Accept the default port number.
9 Enter a proxy URL to hide the direct path to the server.
10 Click Next, review your entries, and click Finish.

For more information about how to define a server, see the SAS Intelligence Platform:
Application Server Administration Guide.
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Overview of Administering SAS Enterprise Guide

SAS Enterprise Guide provides a graphical interface into the SAS programming
language. Wizards and menu options enable you to quickly generate graphical projects,
tasks, and process flows. The process flows analyze data, generate graphs, generate
reports, and publish reports. Behind each process flow is a SAS program that you can
execute and edit.

You can also use SAS Enterprise Guide to register libraries in metadata. The only
other desktop application that registers libraries is SAS Management Console.

As part of the SAS Intelligence Platform, SAS Enterprise Guide is frequently used to
query OLAP cubes and generate stored processes.

After you, the administrator, install SAS Enterprise Guide, you need to help SAS
Enterprise Guide users create connection profiles that enable them to connect to SAS
Metadata Servers. Users might also need your assistance with the selection of SAS
Workspace Servers for data access and remote execution of SAS jobs and programs.

Based on client data access requirements, you also need to ensure that SAS
Enterprise Guide users have permission to access the appropriate libraries, servers, and
data tables.

Additional installation and configuration steps are required to use an ESRI server to
integrate your SAS OLAP cube data with geographic maps using SAS Enterprise Guide.
For information about the ESRI Map Component, see "Configuring the ESRI Map
Component" in the SAS Intelligence Platform: Web Application Administration Guide.

To learn more about SAS Enterprise Guide, see the usage information in the online
Help. Also see Administering SAS Enterprise Guide.
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Administer Connection Profiles in SAS Enterprise Guide

After you install SAS Enterprise Guide, you can create a connection profile for that
user. When selected, the profile connects the user to the specified SAS Metadata Server.
The connection to the metadata server provides secure access to other enterprise
servers and data sources.

The selected profile remains active in subsequent sessions. A connection is made to
the specified server each time the user initializes SAS Enterprise Guide.

Note: Connections depend on the version of the SAS Metadata Server. SAS
Enterprise Guide 4.1 connects only to the SAS 9.1.3 Metadata Server. Similarly, SAS
Enterprise Guide 4.2 and later connect only to the SAS 9.2 Metadata Server. A

SAS Enterprise Guide users might need multiple connection profiles to connect to
multiple SAS Metadata Servers, including the SAS Metadata Servers that might be
installed on their local hosts.

You can administer connection profiles collectively using update configuration files.
When you define and apply an update configuration file, applicable connection profiles
are automatically updated according to the contents of the file. Profiles are updated
when users choose automatic update, and when they select the appropriate update
configuration file. The profiles are updated before the users invoke the profile. For more
information about update configuration files, see Administering SAS Enterprise Guide.

To administer connection profiles, follow these steps:

1 In SAS Enterprise Guide, select Tools » SAS Enterprise Guide Explorer.

2 In the SAS Enterprise Guide Explorer, select File » Manage Profiles.

3 In the Connections window, select Profiles to add, modify, or delete connection
profiles, or select Updates to specify and invoke an update configuration file.
Select servers to specify the default SAS Workspace Server, as described in the
next section.

Click Add to create a new profile.

In the Create Profile window, specify a server name and optional description.

For remote servers, enter a network name in the Machine box.

To simplify support, accept the default port number.

To authenticate users with the user-ID and password that are defined in the

Windows operating environment, select the Use integrated Windows

authentication check box.

9 If an authentication domain has been implemented, enter the name of that domain
in the Authentication domain box. Otherwise, leave the box blank. For
information about authentication domains, see SAS Intelligence Platform: Security
Administration Guide.

10 Click save to add the new profile.

11 To activate the new profile, select it in the Connections window and select set
Active. If a previous connection was active, it is closed and a new connection is
opened. The selected profile is activated each time the user opens SAS Enterprise
Guide. The active profile can be changed at any time.

00 N o O &

Ahout No-Profile Mode

SAS Enterprise Guide users can choose not to use a profile and not to connect to a
SAS Metadata Server. No-profile mode is intended for single-machine configurations.
To invoke no-profile mode, display the Connections window and select Profiles, and
then select <do not use a profile>.
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Select a Default SAS Workspace Server in SAS Enterprise Guide

SAS Workspace Servers execute SAS programs and stored processes as they are
requested by SAS Enterprise Guide. To specify the server that runs SAS for a given
instance of SAS Enterprise Guide, follow these steps:

1 In SAS Enterprise Guide, select Tools » SAS Enterprise Guide Explorer.
2 In the SAS Enterprise Guide Explorer, select File » Manage Profiles.

3 Click servers, and then click the down arrow to select a default SAS server.

Note: Performance improvements can be achieved when groups of users select a
load-balancing cluster of SAS Workspace Servers. For information about
load-balancing, see the SAS Intelligence Platform: Application Server
Administration Guide. A

4 If a SAS Workspace Server exists on the local host, and you want that server to
appear in the list of servers, select the Automatically add local SAS server
(if installed) to the list check box. The server does not need to be
registered on the SAS Metadata Server for this feature.

Create and Manage Libraries in SAS Enterprise Guide

With the Administer permission, you can use SAS Enterprise Guide to create, modify,
and delete libraries. (This is also the case with SAS Management Console.) Select
Tools » Assign Project Library. For information about library management, see
Administering SAS Enterprise Guide.

Review Library Access in SAS Enterprise Guide

When you create a library using SAS Management Console, the library is defined on
the SAS Metadata Server, and the library assignment is shared across SAS servers. In
SAS Enterprise Guide, access to registered libraries is determined in part by the
method that is used to assign those libraries.

To ensure appropriate library access for each SAS Enterprise Guide client, follow
these steps:

1 Start SAS Enterprise Guide and select Tools » SAS Enterprise Guide Explorer.

2 In the left pane, expand Servers and select a SAS Application Server such as
SASApp.

3 After you connect to the server, expand the Libraries node to display the
libraries that are registered in metadata. Libraries with a white library icon are
not pre-assigned to a server in a server initialization command. Libraries that are
pre-assigned, such as WORK, have a yellow library icon.

4 Right-click one of the libraries that you can access from that client, and select
Properties.

5 If the library is pre-assigned, review the library’s path and LIBNAME statement
options, and then click Close.

6 If the library is not pre-assigned, the Library Properties window appears. Select
Assignment.
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7 Review the library assignment method based on the access requirements of the
SAS Enterprise Guide client and the access controls on the registered libraries.
The library assignment methods are defined as follows:

SAS Enterprise Guide

assigns the library based on the engine and LIBNAME statement options that
are defined on the SAS Metadata Server. When you choose this library
assignment method, SAS Enterprise Guide ignores table and column metadata
access control (Read, Write, Create, Delete).

Use this library access method when the client requires Write access to the
library, and when the tables in the library are not subject to access control. If
Write access to a registered library is not required, use Metadata Library
Engine.

Write access to registered libraries should be closely monitored because the
SAS code that is generated by SAS Enterprise Guide does not automatically
synchronize metadata. Changes to columns are written into the physical table,
but are not written into the table metadata.

Note that you can edit the code that is generated by SAS Enterprise Guide to
include the METALIB procedure, which can be used to update table metadata.

SAS Server

assigns the library by merging the library definition from the current SAS
server with the library metadata that is stored on the SAS Metadata Server.
Metadata access control for tables and columns is not enforced. The library is
assumed to be pre-assigned on the SAS server using an AUTOEXEC or the
METAAUTOINIT process that runs when the server is initialized.

Use this library access method to assign a library consistently across clients.
The clients include SAS Enterprise Guide, the SAS Add-In for Microsoft Office,
and the SAS Stored Process Server.

When you create a new library using SAS Enterprise Guide, and select sAs
Server as the library assignment method, the new library is not registered on
the SAS Metadata Server. Use SAS Management Console to register these
libraries.

Metadata Library Engine

assigns the library using the metadata LIBNAME engine. By default, the
library is read-only. You cannot add or create new tables, and SAS Enterprise
Guide displays registered tables only. Use this library assignment method to
protect the referential integrity of the table metadata. This method is
recommended for OLAP cube libraries.

To enable Write access at the library level and enforce metadata access
control at the table and column level, deselect the check box labeled Show only
tables with metadata definitions. With this library access method, SAS
Enterprise Guide displays all of the tables in the library, including any tables
that are not registered.

Note that when you create a new library and specify the Metadata Library
Engine, the library is automatically registered on the SAS Metadata Server.

8 If the assignment method for the selected library does not meet the needs of the
SAS Enterprise Guide client, use SAS Management Console. SAS Management
Console is used to change the library assignment, create new libraries, or change
access permissions.

9 At a minimum, make sure that you review the assignment methods for all of the
registered libraries that require Write access from SAS Enterprise Guide clients.

10 It might be necessary to ask SAS Enterprise Guide users to contact you before
they change a library assignment method.
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Note that the library assignment methods that you select in SAS Enterprise Guide
also apply to the SAS Add-In for Microsoft Office. For more information about the SAS
Add-In for Microsoft Office, see Chapter 3, “Administering the SAS Add-In for Microsoft
Office,” on page 9.

For information about metadata access control, see the "Authorization Model"
chapter of the SAS Intelligence Platform: Security Administration Guide.

For information about pre-assigned libraries, see the "Assigning Libraries" chapter in
the SAS Intelligence Platform: Data Administration Guide.

Generate Diagnostic Logs in SAS Enterprise Guide

Other than the normal SAS log, diagnostic log files are not generated by default in
SAS Enterprise Guide. If you would like to generate log files to help solve a problem,
contact SAS Technical Support.

Default Roles and Capabilities for SAS Enterprise Guide

As described in the SAS Intelligence Platform: Security Administration Guide, you
can assign users to roles to provide access to selected capabilities in the SAS Enterprise
Guide.

Using SAS Management Console, as described in “Administering Roles” on page 69,
you can assign users to roles, change the capabilities that are enabled by each role, and
create new roles with unique sets of capabilities. You can also register new capabilities
for custom tasks.

SAS Enterprise Guide provides four default roles named OLAP, Advanced, Analysis,
and Programming. The following table defines the capabilities that are assigned by
default to the four roles.

Tahle 5.1 Default Capabilities Assigned to Roles for SAS Enterprise Guide

Role

Capability Description Advanced OLAP Analysis Programming
Open or
Import
Category
Open Files from Use the Open File dialog box to X X X X
Local Computer navigate, drag, copy, and paste. Not a

substitute for system security.
Open Cube from  Navigate to OLAP cubes or open cube X X X X
OLAP Server source data.
Open Files from View the server in the tree, navigate to X X

SAS Server

Open Data from
Exchange

the server, and open or import files.
Not a substitute for system security.

Use menus and process flow diagrams X
to open files in Microsoft Exchange.
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Role
Capability Description Advanced OLAP Analysis Programming
Open Data from  Use menus and process flow diagrams X
OLEDB to open files using an installed OLE DB
provider.
Open Data from  Use menus and process flow diagrams X
ODBC to open data sources using an ODBC
provider.
Import Data Enables the Import Data task. X X X X
Save or
Distribute
Category
Save Files to Use the Save File dialog box to X X X X
Local Computer navigate, copy, paste, and drag in the
local file system. Not a substitute for
system security.
Save Files to Use the Save File dialog box to view X X X X
SAS Servers the server file system tree display, and
navigate, copy, paste, and drag in the
file systems of SAS servers. Not a
substitute for system security.
Modify Output Change the output location in tasks X X
Data Location in  and wizards.
SAS Tasks
Copy and Paste Use menus to copy and paste or drag X X X
SAS Server and drop from SAS servers and
Content libraries. Not a substitute for system
security.
Publish To Use the Publish menu to create or X
Distribution modify a publish wizard that sends
Channels content to distribution channels such
as e-mail or Web.
Send Content to  Use the Publish menu options X X X
E-Mail Recipient E-Mail Recipient and E-Mail
Recipient as a Step in
Project to modify a wizard that
distributes files using e-mail.
Content
Category
Create or Modify Use the Query Builder menu X X X
Advanced Query option to create or modify advanced
queries.
Create or Modify Use the Add Table and Join menu X X X

Data Join in
Advanced Query

options to create or modify table joins
in advanced queries.
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Role
Capability Description Advanced OLAP Analysis Programming
Create or Modify  Open, create, and modify SAS code X X
SAS Program nodes in projects. If not granted, users
can still execute SAS programs.
Add or Modify Create or modify SAS code in SAS X X
Custom Code to Enterprise Guide tasks.
SAS Task
Create or Modify  Use the menu options Create X X
SAS Stored Stored Process and Write
Process TaskCode to Stored Process
to create or modify stored processes in
SAS Enterprise Guide projects.
Options
Category
Modify SAS Use the Select Server menu X X X
Server Reference option to change the internal server
in Project or reference for all projects that run on
Document the server.
Modify Security Change security options for projects. X
Options When not granted, users can view
security options.
Modify E-mail Change e-mail options for projects. X X X X
Options When not granted, users can view
e-mail options.
Modify Change performance options for X X
Performance projects. When not granted, users can
Options view performance options.
Modify All Modify all options in the Options dialog X X X X
Options box. When not granted, users can view
options.
Tools and Help
Category
Access Edit or run custom tasks that are not X X X X
Unregistered registered in SAS metadata (unless the
Custom Tasks task is otherwise disallowed).
Modify Styles Use the Style Manager menu X X X X
option to modify the styles that are
used to create reports.
Create or Modify Use the Schedule Project and X X X

Schedules

Schedule Process Flow menu
options to create and modify schedule
projects. When not granted, users can
view schedules.
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Role

Capability Description Advanced OLAP Analysis Programming
Access SAS Use the Enterprise Guide X
Enterprise Explorer menu option to open the
Guide Explorer explorer, or run the executable file from

the operating environment.
Access Project Enables the Assign Project Library X
Library task.
Update Library Enables the Update Library Metadata X X X
Metadata task.
Access Project Open the Project Maintenance dialog X
Maintenance box to rename servers and libraries

throughout a project.
Access SAS Use the menu options under SAS on X X X X
Technical the Web to navigate to the SAS
Support Technical Support Web site from SAS

Enterprise Guide.
Data Category
Append Tables Enables the Append Tables task. X X X X
Delete Data Sets  Enables the Delete Data Sets and X X X X
and Formats Formats task.
Compare Data Enables the Compare Data task. X X X X
Data Set Enables the Compare Data task. X X X X
Attributes
Create Format Enables the Create Format task. X X X X
Random Sample  Enables the Random Sample task. X X X X
Rank Enables the Rank task. X X X X
Sort Data Enables the Sort Data task. X X X X
Standardize Enables the Standardize Data task. X X X X
Data
Split Columns Enables the Split Columns task. X X X X
Stack Columns Enables the Stack Columns task. X X X X
Transpose a set Enables the Transpose task. X X X X
of data
Download Data Enables the Download Data Files to PC X X X X
Files to PC task.
Upload Data Enables the Upload Data Files to X X X X
Files to Server Server task.
Describe
Category
List Report Enables the List Report Wizard task. X X X X
Wizard
Distribution Enables the Distribution Analysis task. X X X X

Analysis
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Role
Capability Description Advanced OLAP Analysis Programming
Characterize Enables the Characterize Data task. X X X X
Data
List Data Enables the List Data task. X X X X
One-Way Enables the One-Way Frequencies task. X X X X
Frequencies
Summary Enables the Summary Statistics task. X X X X
Statistics
Summary Tables Enables the Summary Tables task. X X X X
Table Analysis Enables the Table Analysis task. X X X X
Graph
Category
Contour Plot Enables the Contour Plot task. X X X X
Bubble Plot Enables the Bubble Plot task. X X X X
Radar Chart Enables the Radar Chart task. X X X X
Box Plot Enables the Box Plot task. X X X X
Donut Chart Enables the Donut Chart task. X X X X
Area Plot Enables the Area Plot task. X X X X
Pie Chart Enables the Pie Chart task. X X X X
Line Plot Enables the Line Plot task. X X X X
Bar Chart Enables the Bar Chart task. X X X X
Create Map Enables the Create Map Feature Table X X X X
Feature Table task.
Surface Plot Enables the Surface Plot task. X X X X
Map Graph Enables the Map Graph task. X X X X
Bar-Line Chart Enables the Bar-Line Chart task. X X X X
Tile Chart Enables the Tile Chart task. X X X X
Scatter Plot Enables the Scatter Plot task. X X X X
ANOVA
Category
Linear Models Enables the Linear Models task. X X X X
Mixed Models Enables the Mixed Models task. X X X X
Nonparametric Enables the Nonparametric One-Way X X X X
One-Way ANOVA task.
ANOVA
One-Way Enables the One-Way ANOVA task. X X X X
ANOVA
t Test Enables the t-Test task. X X X X
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Role
Capability Description Advanced OLAP Analysis Programming
Regression
Category
Generalized Enables the Generalized Linear Models X X X X
Linear Models task.
Linear Enables the Linear Regression task. X X X X
Regression
Logistic Enables the Logistic Regression task. X X X X
Regression
Nonlinear Enables the Nonlinear Regression task. X X X X
Regression
Multivariate
Category
Canonical Enables the Canonical Correlation task. X X X X
Correlation
Cluster Analysis  Enables the Cluster Analysis task. X X X X
Correlations Enables the Correlations task. X X X X
Discriminant Enables the Discriminant Analysis X X X X
Analysis task.
Factor Analysis Enables the Factor Analysis task. X X X X
Principal Enables the Principal Components X X X X
Components task.
Survival
Analysis
Category
Life Tables Enables the Life Tables task. X X X X
Proportional Enables the Proportional Hazards task. X X X
Hazards
Capability
Category
CDF Plots Enables the CDF Plots task. X
Histograms Enables the Histograms task. X
Q-Q Plots Enables the Q-Q Plots task. X
Probability Plots  Enables the Probability Plots task. X
P-P Plots Enables the P-P Plots task. X
Control Charts
Category
Box Chart Enables the Box Chart task. X X X X
¢ Chart Enables the ¢ Chart task. X X X X
Individual Enables the Individual Measurements X X X X
Measurements Chart task.

Chart
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Role
Capability Description Advanced OLAP Analysis Programming
np Chart Enables the np Chart task. X X X X
p Chart Enables the p Chart task. X X X X
u Chart Enables the u Chart task. X X X X
Mean and Range Enables the Mean and Range Chart X X X X
Chart task.
Mean and Enables the Mean and Standard X X X X
Standard Deviation Chart task.
Deviation Chart
Pareto
Category
Pareto Chart Enables the Pareto Chart task. X
Time Series
Category
Forecast Studio Enables the Forecast Studio Create X X X X
Create Project Project task.
Forecast Studio Enables the Forecast Studio Open X X X X
Open Project Project task.
Forecast Studio Enables the Forecast Studio Override X X X X
Override Project  Project task.
ARIMA Enables the ARIMA Modeling and X X X X
Modeling and Forecasting task.
Forecasting
Regression Enables the Regression Analysis with X X X X
Analysis with Autoregressive Errors task.
Autoregressive
Errors
Basic Enables the Basic Forecasting task. X X X X
Forecasting
Regression Enables the Regression Analysis of X X X X
Analysis of Panel Data task.
Panel Data
Prepare Time Enables the Prepare Time Series Data X X X X
Series Data task.
Create Time Enables the Create Time Series Data X X X X

Series Data

task.
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Role
Capability Description Advanced OLAP Analysis Programming
Model Scoring
Category
Model Scoring Enables the Model Scoring task. X X X X

Registering Custom Tasks as Capabilities in SAS Enterprise Guide

Overview

Custom add-in tasks are .NET assemblies (DLL files) that you create, deploy, register
in SAS Enterprise Guide, and execute them from the SAS Enterprise Guide task list or
Add-In menu.

To provide access to custom tasks, you can register custom tasks as capabilities,
assign the capabilities to roles, and assign users to roles.

Create Custom Tasks

To create custom tasks, you develop Windows executables and package them as .NET
assemblies. It is convenient to assemble multiple tasks in a single .NET assembly so
that you can share code and implementation among the tasks. For additional
information, sample DLLs, and sample executable source files, see Creating Custom
Add-In Tasks for SAS Enterprise Guide, at

http://support.sas.com/documentation/onlinedoc/guide/customtasks/
index.htm#reference.

Deploy Custom Tasks

You can deploy custom tasks to SAS Enterprise Guide computers in two ways, using
drop-in deployment or add-in deployment. Drop-in deployment copies .NET assemblies
into local directories that are recognized by SAS Enterprise Guide. Custom tasks in
drop-in directories are automatically registered (made available for execution) the next
time the user starts SAS Enterprise Guide.

Add-in deployment copies .NET assemblies into any local directory. You then identify
those directories in SAS Enterprise Guide using the Add-In Manager to make those
tasks available for execution.

When you deploy, make sure that you include any dependent assemblies that are
referenced by your custom tasks. Make sure that you do not include any dependent
assemblies that are provided by SAS Enterprise Guide or the SAS Add-In for Microsoft
Office.

Follow these steps to use the Add-In Manager:

1 Copy the .NET assembly into one of the following directories:
O C:\ProgramFiles\SAS\EnterpriseGuide\release-number\Custom

0O %appdata%\SAS\EnterpriseGuide\release-number\Custom
%appdata% is the Microsoft Window environment variable that maps to a
user account. Repeat the copy in other user accounts if multiple users run
SAS Enterprise Guide on the same host.


http://support.sas.com/documentation/onlinedoc/guide/customtasks/index.htm#reference

2

3

Administering SAS Enterprise Guide /A Apply Custom-Task Capabilities to Roles 55

0O %appdata%\SAS\SharedSettings\release-number\Custom
Use this location to deploy custom tasks to specified user accounts, using a
directory that is accessed by SAS Enterprise Guide and the SAS Add-In for
Microsoft Office.

Restart SAS Enterprise Guide. SAS Enterprise Guide automatically registers the
new custom tasks in the specified directories.

Test the new custom tasks by selecting View » Task List or Tools » Add-In.

Follow these steps to use add—in deployment:

1
2
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Copy the .NET assembly into any local directory.

In SAS Enterprise , start the Add-In Manager in SAS Enterprise Guide. Select
Tools » Add-In » Add-In Manager.

In the Add-In Manager dialog box, select Browse .

Navigate to the directory where you stored your .NET assembly.

Click open to display the names of the custom tasks in the assembly.

Click OK to accept the custom tasks and register them in SAS Enterprise Guide.
Test the new custom tasks by selecting View » Task List or Tools » Add-In.

Register Custom Tasks As Capabhilities

After you deploy custom tasks, follow these steps to register custom tasks as
capabilities:

1

In SAS Enterprise Guide, start SAS Enterprise Guide Explorer. Select Tools »
SAS Enterprise Guide Explorer.

2 In Explorer, select Tools » Task Import Wizard.

3 In the first page of the Task Import Wizard, you see your current metadata profile

connection. If you need to connect with a different profile, click cancel to close the
wizard and select File » Manage Profiles. After you change your profile, click
Close, then start the Task Import Wizard.

In the second page of the Task Import Wizard, specify the location from which you
want to import task definitions. You can choose to have the wizard search
standard locations for task definitions or you can specify a task-definition XML file.

Select tasks to receive metadata and then click Finish in the sixth wizard page to
create metadata.

If you are unable to create metadata, then you might need to install the package
named SAS Enterprise Guide Server Data on the host that contains your current
metadata repository.

Apply Custom-Task Capabilities to Roles

Follow these steps to apply custom-task capabilities to roles:

1
2

In SAS Management Console, open the User Manager.

To create a new role for your custom-task capabilities, right-click in the User
Manager and select New » Role.

To add a custom-task capability to an existing role, double-click a Enterprise
Guide role.

4 In the role properties window, click the capabilities tab.

5 Expand the Plug-Ins branch in the tree view.
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6 Click the custom-task capabilities that you want to add to that role.
7 Click ok.

The custom-task capabilities will be applied to the role the next time affected users
initialize SAS Enterprise Guide.

Note: To access unregistered custom tasks, you need the capability Access
Unregistered Custom Tasks, which is available in the Tools and Help category, as
described in “Default Roles and Capabilities for SAS Enterprise Guide” on page 47. A
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SAS Enterprise Miner Overview for Administrators

SAS Enterprise Miner uses process flows to analyze enterprise data, create predictive
and descriptive models, and interpret the models. The process flows are generated in a
graphical user interface that enables interaction between statistical analysts, IT
professionals, and business analysts. SAS Enterprise Miner also includes a batch
facility to train and score models in batch. SAS Enterprise Miner can be installed in as
distributable client server or as a personal workstation.

Enterprise and Single-Machine Configurations

SAS Enterprise Miner can be installed in a multi-tier client/server configuration, or
the software can be installed in its entirety on a single host. Typical enterprise
installations use SAS Enterprise Miner client software on desktop hosts. The desktop
applications connect to the SAS Metadata Server through a SAS Analytics Platform
server. As part of the SAS Analytics Platform, the SAS Enterprise Miner client
software can be deployed to desktop hosts using Java Web Start.

Installation information is provided in the SAS Intelligence Platform: Installation
and Configuration Guide. The installation of SAS Enterprise Miner fits into the overall
installation process.

For information on installing SAS Enterprise Miner for use by a single user, or to see
any of the latest product documentation, see http://support.sas.com/
documentation/onlinedoc/miner/.

In the Windows operating environment, the SAS Enterprise Miner server software is
installed at SAS-configuration-directory\Levl\AnalyticsPlatform. Client
software is installed at
SAS-installation-directory\SAS\SASAPcore\apps\EnterpriseMiner.

To collect information in a log file, open the file em.ini in SAS-configuration-
directory\Levl\AnalyticsPlatform\apps\EnterpriseMiner\bin and specify a
path and filename for the option applogloc.

The configuration file app.config is located in
SAS-configuration-directory\Levl\AnalyticsPlatform\apps\EnterpriseMiner.


http://support.sas.com/documentation/onlinedoc/miner/
http://support.sas.com/documentation/onlinedoc/miner/
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For information on the contents of the configuration file, see the SAS Enterprise Miner:
Administrator’s Guide.

In an enterprise configuration, you select a workspace server in the Create
Projects section of the SAS Enterprise Miner client application.

About the Enterprise Miner Plug-in for SAS Management Console

The Enterprise Miner plug-in for SAS Management console provides access to the
server attributes, projects, and mining result packages that are defined on the Logical
Workspace Server. You can also configure the Model and Projects folders and identify
an optional WebDAV URL server to publish model packages.

The plug-in is displayed in SAS Management Console after you install and start the
SAS Enterprise Miner client at least once. At that point, you can open the plug-in and
access SAS Enterprise Miner metadata.

For additional information on using the Enterprise Miner plug-in, see the SAS
Enterprise Miner: Administrator’s Guide.

Ahout HTTP Servers

To publish model packages, SAS Enterprise Miner can use a SAS Content Server or
the Apache Tomcat HTTP Server. If your site uses Apache Tomcat, you need to
configure that server as described in the SAS Enterprise Miner Help topic entitled
“Customizing the Apache Tomcat HTTP Server.” You also need to configure SAS
Management Console to identify the HTTP server, using the Models folder. The Models
folder is located under the Enterprise Miner node and the Application Management
node in SAS Management Console.

See also the Help topics under the heading “Preparing SAS Enterprise Miner for
Use.”

To install and register metadata for a SAS Content Server, see the SAS Intelligence
Platform: Application Server Administration Guide.

Clearing the Local Cache for Java Web Start

When you use Java Web Start on the SAS Analytics Platform server, the server
downloads SAS Enterprise Miner and runs the application on your computer. The
downloaded application is stored with other such application in a local cache.
Occasionally, it is necessary to clear the cache, particularly after you install a new
release. Follow these steps to clear the cache:

On the SAS Enterprise Miner client, select Start > Run.

Enter the command javaws viewer.

In the Java Application Cache Viewer, select SAS Enterprise Miner.
Click Remove Selected Application.
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To load the new version of SAS Enterprise Miner, open the Web page for the SAS
Analytics Platform, and then launch the application from the Web page. Use a
Web address such as http://myhost.mydomain.com:6380/AnalyticsPlatform.

To learn more about Java Web Start, see the Administrator’s Guide for SAS Analytics
Platform.
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SAS Information Map Studio Overview for Administrators

SAS Information Map Studio provides a point-and-click interface for the creation and
maintenance of information maps. Information maps are metadata definitions of
enterprise data that provide a basis for querying and reporting.

After you install SAS Information Map Studio, certain administrative tasks need to
be completed. The administrative tasks are summarized in the following table.

Table 7.1 Administrative Tasks for SAS Information Map Studio

Administrative Task Purpose of Task

Add users Create a SAS identity for each person who uses

the SAS environment.

Register resources Make tables, SAS OLAP cubes, and stored
processes available for the creation of SAS

Information Maps.

Administer access control Restrict access to resources in accordance with

your security goals

Introduce pooled workspace servers Enable server-side pooling for relational

databases.
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Administrative Task Purpose of Task

Administer log files Specify the name and location of log files, how to
modify the information that is recorded, and
how to change the name and the location of the

log file.

Allocate memory See "Common Elements" in the SAS Intelligence
Platform: Desktop Application Administration
Guide.

Change or view the application properties Specify the name and location of the file.

Add Users to SAS Information Map Studio

The tasks for adding regular users are specific to SAS Information Map Studio. To
access data through an information map, the user must have Read permission and
ReadMetadata permission on the information map. Users must have an individual
identity other than PUBLIC to log on to SAS Information Map Studio.

For considerations and instructions about setting-up information map users, refer to
the following topics:

0 “Administering Connection Profiles for Desktop Applications” on page 4.

0 “Add Regular Users” in the SAS Intelligence Platform: Security Administration
Guide.

Register Resources as Input to SAS Information Maps

Tables, Cubes, and Stored Processes

SAS Information Map Studio accesses tables, cubes, and stored processes through the
SAS Metadata Server. These resources are available only if they are registered in the
metadata.

The following restrictions apply to these resources:

0 Tables must be uniquely named and must be associated with a library that is
assigned to a SAS Application Server. The tables can be any combination of SAS
data sets and third-party relational database tables.

0 SAS OLAP cubes must be uniquely named and must be associated with an OLAP
schema that is assigned to a SAS Application Server.

0 Stored processes must be on the same SAS Application Server as the tables that
are used by the information map. The stored process must be hosted by a SAS
Workspace Server.

User-Defined Formats

If you have existing SAS data sets, you might also have a catalog of user-defined
formats and informats. You have two options for making these formats available to
applications such as SAS Information Map Studio:

0 Give the format catalog a standard name and place it in an expected location. This
is the preferred method.
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O Create a user-defined formats configuration file, and use the FMTSEARCH system
option to point to the format catalog.

For detailed instructions about both options, see “Connecting to Common Data
Sources” in the SAS Intelligence Platform: Data Administration Guide.

Access Control for SAS Information Maps

Information maps inherit permissions from their folders. The folders in turn inherit
permissions from their parent folders. Folder permissions are not set in SAS
Information Map Studio. Permissions can be applied in SAS Information Map Studio to
SAS Information Maps within a folder.

WriteMetadata permission is needed on the information map to modify permissions
or view any authorization-based prefilter assignments.

You can also apply BI row-level permissions through information maps. For details,
see “BI Row-Level Permissions” in the SAS Intelligence Platform: Security
Administration Guide.

To define access to an information map from within SAS Information Map Studio:

1 Open an information map or, if working with an unsaved information map, save it.
2 Select Tools » Authorization.

3 Modify the permission settings as necessary.

4 Close the dialog box.

5 Save the information map for the changes take effect.

For additional information, see the SAS Information Map Studio Help and Chapter
“Common Elements,” on page 3.

N

Access Control for Sets of Information Maps

Proper storage of information maps enables you to easily do the following:
O manage the access controls for sets of information maps

O ensure that the information maps are available as resources for queries and report
writing

To manage the access controls for sets of information maps, create subfolders under
SAS Folders in the Folders tab of SAS Management Console. For example, you can
add a folder for Human Resources and set access controls so the Human Resources user
group has exclusive access to the Human Resources information map folder. The
folder’s access controls are inherited by all of the information maps within that folder.

Pooled Workspace Server

You can use SAS Information Map Studio to support server-side pooling for relational
databases. The use of this server pool is governed by the authentication rules that are
set in the SAS Metadata Server. A pooled workspace server is configured in the
library’s information maps that include queries of relational databases.

o0 Information maps that do include queries of relational databases are intended to
run on a SAS Pooled Workspace Server.
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o If a pooled workspace server is not defined or available, the query attempts to use
a SAS Workspace Server.

Note: OLAP-defined information maps and the queries are always run on the OLAP
server. A

For detailed information about workspace server pooling, see “Load Balancing and
Pooling” in the SAS Intelligence Platform: Application Server Administration Guide.

Log Files

Application Log

SAS Information Map Studio records selected events that occur while running the
application. Error data for specific components or Java packages are recorded. In order
to record diagnostic information, your application must have Write access to the log file
on the operating system’s file system.

To change the information that is recorded, or to change the name or location of the
log file, follow these steps:

1 Exit the application.

2 Open SAS-installation-
directory\SAS\SASInformationMapStudio\release-number\mapstudio.ini.

3 Add -loggingSetupDialog to the end of the MainClass statement, save, and
close the file.

4 Start the application. The Diagnostic Settings dialog box is displayed.

5 In the severity level drop-down list, select the severity level for recording
information for the entire application.

6 (Optional) Record a different level of information for a particular component or
Java package. Select the Component or Java package to specify the Severity
level.

7 The Log file box specifies the output log file that stores the error data. Set a
new file or location, as needed.

8 Select OK to begin using the new diagnostic settings.
In general, it is best to modify this file under the direction of SAS Technical Support.

For additional information, see “Administering Logs and Other Local Files” on page 6
and the SAS Information Map Studio Help.

Note: If you run your application on a Citrix server, then the log file is located on
the Citrix server machine. A

Resource Replacement Log

Information map resources can be replaced after an information map is created. The
Resource Replacement dialog box is used to replace external metadata resources that
are referenced by the information map. The application records to the log file the
replacement tasks that were performed, and any issues that were encountered.

For additional information, see SAS Information Map Studio Help.
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Copy to Folder Log

When the Copy to Folder feature in the resource pane is used, a copy-paste log file is
generated to record the events.

The Windows Log File location is C: \Documents and Settings\User
Id\Application Data\SAS\SASIinformationMapStudio\release-number.

The Vista Log File location is C:\Users\User
Id\AppData\Roaming\SAS\SASIinformationMapStudio\release-number.

Memory Allocation

SAS Information Map Studio dynamically allocates memory to support its user
interface. For additional information, see “Managing the Java Heap Used By Desktop
Applications” on page 7.

Configuration File

The configuration file for SAS Information Map Studio is located in the default
installation directory
SAS-installation-directory\SAS\SASInformationMapStudio\release-number.
The name of the file is mapstudio.ini. Each installation of the SAS Information Map
Studio application has its own configuration file.

Note: In general, it is best to modify this file under the direction of SAS Technical
Support. A
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SAS Management Console Overview for Administrators

SAS Management Console is the primary administrative interface for the SAS
Intelligence Platform. Use it to manage servers, libraries, security, metadata objects,
roles, logs, backup and recovery, scheduling, and message queues.

Because of its powerful capabilities, you should limit the number of clients that
receive SAS Management Console. Grant administrative permissions only to trusted
and experienced individuals. Also consider the use of roles to prevent users from seeing
plug-ins that do not apply to their jobs. For example, a user can be given a role that
displays the Library Manager without displaying the Server Manager or the User
Manager.

SAS Management Console is structured as a series of Java plug-ins, each of which
provide a specific administrative function. A number of plug-ins are delivered to all
customers, such as the Server Manager plug-in. Other plug-ins are delivered based on
your site license, such as the administrative plug-in for SAS Enterprise Miner.

Quick Reference for SAS Management Console

Each plug-in in SAS Management Console has its own set of Help information. To
access plug-in Help, either click a Help button in a window or select the plug-in in the
Plug-ins tab and choose the Help from the Help menu.

The following table lists tasks and related components in SAS Management Console:
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Table 8.1 Quick Reference for SAS Management Console

Task

Component

Reference

Security: manage permissions
for users and groups

Authorization Manager, Access
Control Templates folder

See the SAS Management
Console: Guide to Users and
Permissions.

Security: manage permissions
for metadata objects

Authorization Manager,
Resource Management folder

See the SAS Intelligence
Platform: Security
Administration Guide

Security: connection profiles,
domains, and Integrated
Windows authentication

Connection Profile Wizard

See the Help for the
Connection Profile Wizard.
Select File » Connection
Profile and click Help.

Libraries: create and register

Data Library Manager

See the SAS Intelligence
Platform: Data Administration
Guide.

Web application logs,
connections, discovery, events,
sessions, security, stored
processes: manage services

Foundation Services

See the Help for Foundation
Services in SAS Management
Console.

Server control, initialization,
log configuration, and options

Server Manager

See the SAS Intelligence
Platform: System
Administration Guide

Users and roles

User Manager

See the SAS Intelligence
Platform: Security
Administration Guide and the
SAS Management Console:
Guide to Users and
Permissions.

Create and import packages,
transfer data between folders.

Folders tab

See the Help for SAS
Management Console.

Metadata objects: register,
manage, configure libraries,
tables, jobs, stored processes,
and so on.

Folders tab

See Help on Folders in SAS
Management Console.

SAS Metadata Server: manage
resource templates, replicate,
backup, and restore

Metadata Manager

See the SAS Intelligence
Platform: System
Administration Guide.

Publishing: manage e-mail
accounts, channels,
subscribers, message queues

Publishing Framework

See the Help for the Publishing
Framework in SAS

Management Console.

Scheduling: create and manage
flows, execute jobs with
available dependencies.

Schedule Manager

See Scheduling in SAS.

Servers, spawners, external
data connections: define,
control, manage

Server Manager
SAS OLAP Server Monitor

See the SAS Intelligence
Platform: Application Server
Administration Guide and the
Help for SAS OLAP Server
Monitor and Server Manager.
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Task Component Reference

Applications: manage and Foundation Services Manager See the Help for these plug-ins.
monitor custom Application Monitor

Configuration Manager

Manage the Web Configuration Manager See the SAS Intelligence
Infrastructure Platform Platform: Web Application
Administration Guide.

Test deployments Deployment Tester See "Monitoring Applications"
in SAS Management Console
Help. Also see "Validating
Logical Servers" in SAS
Management Console Help.

Geographic maps: define, Map Service Manager See the SAS Intelligence
import services. Under Platform: Web Application
separate license, works with Administration Guide.

ArcGIS software to embed
OLAP data in geographic
displays.

Understanding the Configuration of SAS Management Console

The following administrative and configuration files for SAS Management Console
are located on each client:

sasmec.ini
contains configuration settings for SAS Management Console. The default storage
location is SAS-installation-directory\SAS\SASManagementConsole\9.x.

app.smc
contains the user profile for SAS Management Console. The default storage
location for Windows is C:\Documents and Settings\user name\Application
Data\SAS\SASManagementConsole\9.x. The default storage location for the Vista
operating environment begins with
C:\Users\user_name\AppData\Roaming\SAS\9.x.

Redirecting Local Files Created hy SAS Management Console

By default, SAS Management Console stores the log files, application default files,
and connection profiles on the local host. To change the default storage location, follow
these steps:

1 Close SAS Management Console on the local host.
2 Create the path and directory for the client files.
3 Open the file sasmc.ini and add the following Java argument:
JavaArgs_xx=-Dsas.appdatapath="new_path"
xx is the next available Java argument number, and new_path is a fully qualified
path to the new directory. Here is a typical example:

JavaArgs_1l2=-Dsas.appdatapath="\\adminServer02\SMCClientFiles\Hostd17362"
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4 Start SAS Management Console on the local host.

Starting SAS Management Console

Start Commands

In the Windows operating environment, you can start SAS Management Console by
selecting Start » Programs » SAS » SAS Management Console. You can also start
the application from a command line. Navigate to the SAS Management Console
installation directory and issue the command for your platform, as listed in the
following table.

Tahle 8.2 SAS Management Console Startup Commands

Platform Command
Windows sasmc.exe
64-bit enabled Solaris J/sasmc
64-bit enabled AIX Jsasmc

In the UNIX operating environment, you can use a symbolic link to start SAS
Management Console. The following examples of UNIX commands create the symbolic
link and start SAS Management Console:

> 1n -s /usr/local/SAS/SASManagementConsole/9.3/sasmc /usr/local/bin/sasmc
> sasmc

If you do not specify any options, SAS Management Console uses the parameters
specified in the sasmec.ini file. The following sections contain information about options
that you can specify on the command line or add to the sasmc.ini file.

Specify Java Options

To specify Java options when you start SAS Management Console, use the
-javaopts option and enclose the Java options in single quotation marks. For example,
the following command starts SAS Management Console on Windows and contains Java
options that specify the locale as Japanese.

sasmc -javaopts ’‘-Duser.language=ja -Duser.country=JP’

Specify the Plug-in Location

By default, SAS Management Console looks for plug-ins in a plugins directory
under the directory in which the application was installed. If you are starting SAS
Management Console from another location, you must specify the location of the
directory by using the -pluginsDir option. The syntax of the option is as follows:

sasmc -pluginsdir <plugin-path>
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Administering Connection Profiles in SAS Management Console

During initialization, SAS Management Console connects to a SAS Metadata Server
that is identified in a connection profile. You need to create one profile for each SAS
Metadata Server if you have more than one. You might also need to create separate
profiles if you want to connect as an administrator or as the unrestricted user. For
information about the creation of connection profiles, see “Administering Connection
Profiles for Desktop Applications” on page 4.

Ahout the Folders Tah

The Folders tab provides a categorized folder tree that displays the objects that
have been registered in metadata on the currently connected SAS Metadata Server. In
the Folders tab, you can do the following:

O create new stored processes
O import and export folders and metadata objects
O delete folders and metadata objects

o display and modify the properties and permissions of folders and metadata objects

These actions are made available depending on your current set of permissions.

Some of the top-level folders have Content Mapping properties. These properties
determine whether additions and deletions relate to metadata definitions only, or to
metadata definitions and their respective physical files. By default, additions and
deletions affect metadata objects only. Administrators can set Content Mapping
properties as needed to synchronize metadata changes and physical changes.

Administering Roles

As described in the SAS Intelligence Platform: Security Administration Guide, the
User Manager in SAS Management Console provides roles and capabilities that can be
applied to users. When a user profile is associated with a role, that user has access to
the capabilities that are selected for that role in the User Manager.

Opening the User Manager displays roles for the following desktop applications:

0 SAS Management Console

0 SAS Add-In for Microsoft Office (see “Registering Custom Tasks as Capabilities in
the SAS Add-In for Microsoft Office” on page 19)

0 SAS Enterprise Guide (see “Default Roles and Capabilities for SAS Enterprise
Guide” on page 47)

o SAS Web Report Studio (see the SAS Intelligence Platform: Web Application
Administration Guide)

SAS Management Console provides two default roles: Advanced and Content
Management. The following table describes the capabilities that are assigned to those
roles by default. In the User Manager, you can change the capabilities of a role or add
new roles with unique sets of capabilities.
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Tahle 8.3 Default Capabilities Assigned to Roles for SAS Management Console

Role
Capability Description Advanced Content
Management
General Category
Access Unregistered Access plug-ins that are not registered in metadata. X
Plug-ins
Plug-ins Category
Application Monitor Monitor the activities of applications, subsystems X
and services.
Authorization Manager Manage resource access control policies. X X
Data Library Manager Manage the definitions of data libraries and X X
database schemas.
Folder View Manage public and user folders used to store X X
metadata objects.
Foundation Services Manage Foundation Services components. X
Manager
Metadata Manager Create and manage metadata repositories, manage X
the current SAS Metadata Server, and run
metadata utilities.
Publishing Framework Manage publishing framework subscribers and X
content channels.
Schedule Manager Manage SAS jobs to be scheduled, create X
conditional events for schedules, and submit jobs
for scheduling.
Server Manager Create and manage server definitions (such as for
SAS servers, database servers, and spawners).
User Manager Create and manage users, groups, roles, and X X

capabilities.
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SAS OLAP Cube Studio Overview for Administrators

SAS OLAP Cube Studio is used to build, edit, and tune OLAP cubes. To build a cube,
the application generates metadata and a SAS program. It then submits the program
for execution on a SAS Workspace Server. The SAS Workspace Server builds the cube
and stores the result in a physical location that can be accessed by a SAS OLAP Server.

When a cube becomes available on a SAS OLAP Server, it is queried by users
working with OLAP clients. These clients can include SAS Web Report Studio, SAS
Web OLAP Viewer, and SAS Enterprise Guide. The cube viewers submit queries to the
SAS OLAP Server in the industry-standard MDX query language. The SAS OLAP
Server responds to queries by delivering result sets to the cube viewers for display.

To configure your enterprise for SAS OLAP Cube Studio, perform the following tasks:

Install and register SAS OLAP Servers and SAS Workspace Servers.
Create libraries for cubes and cube data.
Set up users, groups, and roles for OLAP cube builds, updates, and queries.

Use the OLAP Server Monitor and Server Manager plug-ins in SAS Management
Console to monitor, control, and tune SAS OLAP Servers.

O

O o o

For information about the administration of SAS OLAP Servers, see the chapter
“Administering SAS OLAP Servers” in the SAS Intelligence Platform: Application
Server Administration Guide.

Setting Up the SAS Intelligence Platform for SAS OLAP Cube Studio

Set up the SAS Intelligence Platform as follows to use SAS OLAP Cube Studio:

1 Install, configure, and start a host that runs both a SAS Workspace Server and a
SAS OLAP Server. This step generally occurs at initial deployment, as described
in the SAS Intelligence Platform: Installation and Configuration Guide.

2 Define libraries and data sources, as described in the SAS Intelligence Platform:
Data Administration Guide.
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3 Define access controls for libraries, users of SAS OLAP Cube Studio, and users of
cube viewers. After you build a cube, you can apply access controls within the
cube, including member—level access controls, as described in the SAS Intelligence
Platform: Security Administration Guide.

4 Set up connection profiles and roles for OLAP users, as described in Chapter 2,
“Common Elements,” on page 3.

Understanding the Configuration of SAS OLAP Cube Studio

The following administrative and configuration files for SAS OLAP Cube Studio are
located on each client:

olapa.ini
contains configuration settings for SAS OLAP Cube Studio. The default storage
location is
SAS-installation-directory\SAS\SASOLAPCubeStudio\release-number.

CubeStudioDefaults.txt
contains the user properties for SAS OLAP Cube Studio. The default storage
location is C:\Documents and Settings\User ID\Application
Data\SAS\SASOLAPCubeStudio\release-number.

Log files
C:\Documents and Settings\user name\Application
Data\SAS\SASOLAPCubeStudio

Log files in the Vista operating environment
C:\Users\user name\AppData\Roaming\SAS\SASOLAPCubeStudio

Administering OLAP Sessions and Queries

The SAS OLAP Server Monitor plug-in for SAS Management Console displays
information about client connections to SAS OLAP Servers. Connecting to one of those
servers displays a list of active queries on that server. You can close selected sessions or
queries. For more information about the SAS OLAP Server Monitor, see “Administering
SAS OLAP Servers” in SAS Intelligence Platform: Application Server Administration
Guide. Also see the SAS OLAP Server Monitor Help.

Administering SAS OLAP Servers

SAS OLAP Server administration takes place in the Server Manager and the SAS
OLAP Server Monitor plug-ins in SAS Management Console. Certain server control
functions are also available from SAS OLAP Cube Studio.

Use the Server Manager plug-in to set options on SAS OLAP Servers. Open the
server’s properties window, select Options, and select Advanced Options.

Use the Server Manager or the SAS OLAP Server Monitor to stop, pause, and
quiesce SAS OLAP Servers in support of cube builds and cube updates. For more
information about stopping and starting servers, see the SAS Intelligence Platform:
System Administration Guide.
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Recommended Reading

Recommended Reading 13

Recommended Reading

Here is the recommended reading list for this title:
0 SAS Intelligence Platform: Ouverview
SAS Intelligence Platform: System Administration Guide
SAS Intelligence Platform: Web Application Administration Guide
SAS Intelligence Platform: Security Administration Guide
SAS Intelligence Platform: Data Administration Guide

SAS Add-In for Microsoft Office: Adding SAS Content to Your Microsoft Office
Documents

SAS Data Integration Studio: User’s Guide

O o o o d

O
0 Administering SAS Enterprise Guide

O Getting Started with SAS Enterprise Miner

0 SAS Information Map Studio: Tips and Techniques
0 SAS OLAP Server: User’s Guide

For a complete list of SAS publications, go to support.sas.com/bookstore. If you
have questions about which titles you need, please contact a SAS Publishing Sales
Representative at:

SAS Publishing Sales

SAS Campus Drive

Cary, NC 27513

Telephone: 1-800-727-3228

Fax: 1-919-531-9439

E-mail: sasbook@sas.com

Web address: support.sas.com/bookstore

Customers outside the United States and Canada, please contact your local SAS office
for assistance.
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Glossary

connection profile
a client-side definition of where a metadata server is located. The definition includes
a computer name and a port number. In addition, the connection profile can also
contain user connection information.

metadata repository
a collection of related metadata objects, such as the metadata for a set of tables and
columns that are maintained by an application. A SAS Metadata Repository is an
example.

metadata server
a server that provides metadata management services to one or more client
applications. A SAS Metadata Server is an example.

OLAP
See online analytical processing.

online analytical processing
a software technology that enables users to dynamically analyze data that is stored
in multidimensional database (MDDB) tables. Short form: OLAP.

SAS Management Console
a Java application that provides a single user interface for performing SAS
administrative tasks.

SAS Metadata Repository
a repository that is used by the SAS Metadata Server to store and retrieve metadata.
See also SAS Metadata Server.

SAS Metadata Server
a multi-user server that enables users to read metadata from or write metadata to
one or more SAS Metadata Repositories. The SAS Metadata Server uses the
Integrated Object Model (IOM), which is provided with SAS Integration Technologies,
to communicate with clients and with other servers.

SAS OLAP Cube Studio
a Java interface for defining and building OLAP cubes in SAS System 9 or later. Its
main feature is the Cube Designer wizard, which guides you through the process of
registering and creating cubes.
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SAS OLAP Server
a SAS server that provides access to multidimensional data. The data is queried
using the multidimensional expressions (MDX) language.

schema
a map or model of the overall data structure of a database. An OLAP schema
specifies which group of cubes an OLAP server can access.

star schema
tables in a database in which a single fact table is connected to multiple dimension
tables. This is visually represented in a star pattern. SAS OLAP cubes can be
created from a star schema.

tuple
a data object that contains two or more components. In OLAP, a tuple is a slice of
data from a cube. It is a selection of members (or cells) across dimensions in a cube.
It can also be viewed as a cross-section of member data in a cube. For example,
([time].[all time].[2003], [geographyl.[all geography].[u.s.a.], [measures].[actualsum])
is a tuple that contains data from the Time, Geography, and Measures dimensions.

wizard
an interactive utility program that consists of a series of dialog boxes, windows, or
pages. Users supply information in each dialog box, window, or page, and the wizard
uses that information to perform a task.
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